[OH 2.4.0 M6] Testing Results

openhab2
testing
milestone
Tags: #<Tag:0x00007fe0635e1cd0> #<Tag:0x00007fe0635e1578> #<Tag:0x00007fe0635e1190>

(Angelos) #71

your RAM may be all used up… (this can be a problem on SBCs)
what is the output of:

free
(or cat /proc/meminfo |grep -i swap)

(Kristof Rado) #72

I’m monitoring the memory usage for days, and it is always almost full, but not not entirely.

          total        used        free      shared  buff/cache   available
Mem:         864188      660408       56528        5060      147252      144844
Swap:        102396       72704       29692

However that’s the one I thought of, because sometimes I saw errors in openHab, that it can’t allocate memory for something… another guess for me is disk I/O. I had a previous problem where rules stopped working and that was because of the I/O, it was just too slow to write everything to the SD. Now I have solved this, I’m using MySQL on my NAS, so not locally and also moved the logs to the NAS…


(Markus Storm) #73

Disk I/O (usually) isn’t a bottleneck in terms of performance, nevertheless you should still move all write-intensive data storage over to your NAS to avoid getting hit by SD corruption.

The largest benefit will be in swapping [well, paging to use the correct term] to NAS, too. See this post.

Either way, please stay on topic. Open a new thread if you want to discuss server optimizations.


(Kristof Rado) #74

Sorry for spamming this post, but it seemed that this problem is related to M6.
Anyway it seems it solved itself


(Rick) #75

hey guys, I’ve just updated to m6 from 2.3. ive cleared the cache but openhab won’t start and in the log I have the following.

2018-12-02 08:15:13.905 [SEVERE] [org.apache.karaf.main.Main] - Could not launch framework
java.lang.RuntimeException: Error initializing storage.
at org.eclipse.osgi.internal.framework.EquinoxContainer.(EquinoxContainer.java:70)
at org.eclipse.osgi.launch.Equinox.(Equinox.java:31)
at org.eclipse.osgi.launch.EquinoxFactory.newFramework(EquinoxFactory.java:24)
at org.apache.karaf.main.Main.launch(Main.java:256)
at org.apache.karaf.main.Main.main(Main.java:178)
Caused by: java.io.FileNotFoundException: /var/lib/openhab2/cache/org.eclipse.osgi/.manager/.fileTableLock (Permission denied)
at java.io.RandomAccessFile.open0(Native Method)
at java.io.RandomAccessFile.open(RandomAccessFile.java:316)
at java.io.RandomAccessFile.(RandomAccessFile.java:243)
at org.eclipse.osgi.internal.location.Locker_JavaNio.lock(Locker_JavaNio.java:36)
at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.java:388)
at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:701)
at org.eclipse.osgi.storage.Storage.getChildStorageManager(Storage.java:1776)
at org.eclipse.osgi.storage.Storage.getInfoInputStream(Storage.java:1793)
at org.eclipse.osgi.storage.Storage.(Storage.java:132)
at org.eclipse.osgi.storage.Storage.createStorage(Storage.java:85)
at org.eclipse.osgi.internal.framework.EquinoxContainer.(EquinoxContainer.java:68)
… 4 more
any ideas how to fit the permission issue?


(Angelos) #76

How did you upgrade?

post the output of

openhab-cli info

#1, #9


(Rick) #77

here is the output.
I used the openhababian config

Version: 2.4.0.M6 (Build)

User: openhab (Active Process 22767)
User Groups: openhab tty dialout audio bluetooth gpio

Directories: Folder Name | Path | User:Group
----------- | ---- | ----------
OPENHAB_HOME | /usr/share/openhab2 | openhab:openhab
OPENHAB_RUNTIME | /usr/share/openhab2/runtime | openhab:openhab
OPENHAB_USERDATA | /var/lib/openhab2 | openhab:openhabian
OPENHAB_CONF | /etc/openhab2 | openhab:openhabian
OPENHAB_LOGDIR | /var/log/openhab2 | openhab:openhabian

URLs: http://192.168.178.42:8080
https://192.168.178.42:8443


(Angelos) #78

I didn’t know that the openhabian config tool allows you to use Milestone builds.
I though that you could choose only between stable (2.3.0) and snapshot (2.4.0.S)

anyway, try:

sudo su
systemctl stop openhab2
mv /var/log/openhab2/openhab.log /var/log/openhab2/openhab.log.old
chown -R openhab:openhab  /var/lib/openhab2/
systemctl start openhab2
tail -f /var/log/openhab2/openhab.log

then,

apt-get update && apt-get upgrade

to get the new one: [OH 2.4.0 M7] Testing Results :slight_smile:


(Angelos) #79

time to upgrade people! Let’s make OH2.4 the most stable release ever ! :wink:


(Rick) #80

upgrading to m7 fixed it


(Markus Storm) #81

We introduced that a couple of weeks ago.


(Kim Andersen) #82

I cant find the milestone build in the openhabian-config ??
I just tried testing and snapshot, and both gave me the #1447 release…


(Markus Storm) #83

testing should be giving you the milestone builds … raise a Github issue and preceisely describe the config you start from and steps you tried to get the milestone build.


(Angelos) #84

It seems that he got it to work from the openhabian-config:


(Markus Storm) #85

Yes that’s what’s in openHABian for testing.
I use http://openhab.jfrog.io/openhab/openhab-linuxpkg testing main (which essentially is the same base location as the unstable repo except the testing tag of course) and get my milestone builds from there.
I recall discussing with Benjy and that there was some recent change, but I don’t find the reference any more.
@Benjy can you please state which is the current testing repo to be used for milestone builds ?


(Angelos) #86

I think the “official” testing is deb https://dl.bintray.com/openhab/apt-repo2 testing main

See here: https://www.openhab.org/download/


(Markus Storm) #87

Not sure if that docs statement is up to date. And as you pointed out yourself it’s what he used and he said it didn’t give him the milestone but the latest snapshot.


(Angelos) #88

It seems that he was wrong.

According to my understanding, he posted here first that he used testing and was getting snapshot but later he posted in the M7 thread trying to install the milestone where the sources were pointing to bintray (so the openHABian config tool updated them correctly).

Snapshots are on openhab.jfrog.io and his apt doesn’t use it (of course, he could have manually edited the lists).

I found this: Openhab2 2.4.0-M2

I think that this is up-to-date: https://github.com/openhab/website/blob/master/.vuepress/public/v2.3/docs/installation/linux.html

edit: I just checked and the testing repo does not contain Snapshot builds. Only Stable and Milestones. So he couldn’t be receiving Snapshots from testing.


(Markus Storm) #89

Ok, I just changed my repo to bintray testing and it didn’t result in any package to get installed (I’m on M7) so that’s obviously ok.
I recall that if you were on snapshot and wanted to move to milestone you had to explicitly add the package version in apt-get install so that’s what might have happened, but I don’t know if that’s still a valid statement. @Benjy I believe you changed that ?


(Angelos) #90

I think that the opposite is true (to go from Milestone to Snapshot you need to specify the version)

I remember the following (happened to me also): When the Milestones appeared on the unstable (Snapshot) repo, they were treated as upgrades to the Snapshots and you would get “stuck” on M2 for example even if a newer Snapshot was released (apt-get upgrade was not pulling the newer snapshot).

To avoid this, Benjy removed the Milestone builds from the unstable repo and he placed them only on the testing repo.

Also found this post: openHAB 2.4 Milestone builds