[OH 2.4.0 M6] Testing Results

openhab2
testing
milestone
Tags: #<Tag:0x00007f0146b95d90> #<Tag:0x00007f0146b95c28> #<Tag:0x00007f0146b95ac0>

(Angelos) #79

time to upgrade people! Let’s make OH2.4 the most stable release ever ! :wink:


(Rick) #80

upgrading to m7 fixed it


(Markus Storm) #81

We introduced that a couple of weeks ago.


(Kim Andersen) #82

I cant find the milestone build in the openhabian-config ??
I just tried testing and snapshot, and both gave me the #1447 release…


(Markus Storm) #83

testing should be giving you the milestone builds … raise a Github issue and preceisely describe the config you start from and steps you tried to get the milestone build.


(Angelos) #84

It seems that he got it to work from the openhabian-config:


(Markus Storm) #85

Yes that’s what’s in openHABian for testing.
I use http://openhab.jfrog.io/openhab/openhab-linuxpkg testing main (which essentially is the same base location as the unstable repo except the testing tag of course) and get my milestone builds from there.
I recall discussing with Benjy and that there was some recent change, but I don’t find the reference any more.
@Benjy can you please state which is the current testing repo to be used for milestone builds ?


(Angelos) #86

I think the “official” testing is deb https://dl.bintray.com/openhab/apt-repo2 testing main

See here: https://www.openhab.org/download/


(Markus Storm) #87

Not sure if that docs statement is up to date. And as you pointed out yourself it’s what he used and he said it didn’t give him the milestone but the latest snapshot.


(Angelos) #88

It seems that he was wrong.

According to my understanding, he posted here first that he used testing and was getting snapshot but later he posted in the M7 thread trying to install the milestone where the sources were pointing to bintray (so the openHABian config tool updated them correctly).

Snapshots are on openhab.jfrog.io and his apt doesn’t use it (of course, he could have manually edited the lists).

I found this: Openhab2 2.4.0-M2

I think that this is up-to-date: https://github.com/openhab/website/blob/master/.vuepress/public/v2.3/docs/installation/linux.html

edit: I just checked and the testing repo does not contain Snapshot builds. Only Stable and Milestones. So he couldn’t be receiving Snapshots from testing.


(Markus Storm) #89

Ok, I just changed my repo to bintray testing and it didn’t result in any package to get installed (I’m on M7) so that’s obviously ok.
I recall that if you were on snapshot and wanted to move to milestone you had to explicitly add the package version in apt-get install so that’s what might have happened, but I don’t know if that’s still a valid statement. @Benjy I believe you changed that ?


(Angelos) #90

I think that the opposite is true (to go from Milestone to Snapshot you need to specify the version)

I remember the following (happened to me also): When the Milestones appeared on the unstable (Snapshot) repo, they were treated as upgrades to the Snapshots and you would get “stuck” on M2 for example even if a newer Snapshot was released (apt-get upgrade was not pulling the newer snapshot).

To avoid this, Benjy removed the Milestone builds from the unstable repo and he placed them only on the testing repo.

Also found this post: openHAB 2.4 Milestone builds


(Kim Andersen) #91

No, I got it from the command line. Not from openhabian-config. I tried both testing and snapshot. Both gave me the #1447 release.


(Kim Andersen) #92

But I did… I first tried snapshot, it gave me #1447. Then I tried testing. And it gave me #1447 as well.


(Angelos) #93

what do you mean? did you modify /etc/apt/sources.list.d/openhab2.list or you used the openHABian tool to change this?

the testing repo does not have the snapshots, so you couldn’t have gotten the S1447

did you run apt-get update after changing the apt list?


(Kim Andersen) #94

I didn´t change anything beforehand.
I was running #1445.

I then entered openhabian-config, and choose the snapshot.
I ended up with the #1447

I then entered openhabian-config again and choose the testing
I ended up with #1447 again…
Thats why I wrote, in the M7 thread, that I couldn´t get the Milestone.

In the end, I got the M7 when I used the apt-get from the commandline, as you suggested in the M7 thread.


(Angelos) #95

maybe the script within openHABian does not run apt-get update after changing the repos in the list. Not sure if it is supposed to do this. Maybe it just updates the list file without actually running update & upgrade… I will check the github code to see how it works.

Anyway, you need to run apt-get update after changing the list file (like you did and you finally got M7)


(Angelos) #96

yeah… it should have deployed M7 when you selected testing… .strange

Maybe open an issue on https://github.com/openhab/openhabian/issues ?


(Kim Andersen) #97

Yeah, I just thought I could get the M7 from within openhabian-config. As Markus wrote, choosing the testing should given me the Milestone release. I guess that didn´t work for me.

I´m not sure if it´s my setup… It a pretty new (testing) setup I installed a coupple of days ago, where I first installed the 2.3 stable, and then used openhabian-config to upgrade to #1445.
When M7 was release yesterday, I tried to upgrade to M7… Which is where this lead to…
Cant see what I could have done wrong.


(Ben Clark) #99

To clarify, snapshots are always considered newer than the milestone releases (2.4.0~M# < 2.4.0~S#) and has always been the case (2.4.0~M# < 2.4.0~#) there was previously a bug that labeled the milestone as (2.4.0.M#) but this has been resolved.

  • To change from milestone to snapshot, just change the repo and upgrade.

  • To change from anything to release of the same version, just change the repo and upgrade.

  • To change from any snapshot to a milestone, you need to specify the version, in this case: openhab2=2.4.0~M7-1

Hope that helps!