OH 2.5 M2: no Initial load of status of knx items at startup anymore

Tags: #<Tag:0x00007fc1ff85dc98>

Since updating to 2.5. M2 states of knx items are not loaded at startup anymore. Did I do a mistake or is it a bug?

Thanks for any hints…

Restart at least 3 times. I’ve noticed that jumping version to version can cause issues occasionally with things loading in the correct order. Give at least 5 minutes between restarts. See if that clears it out.

I have already rebooted about 4 times…so far no result

… I can confirm that after updating to 2.5M2 knx-status is not received from the knx-bus. Back to 2.5M1 does work properly. I also have rebooted several times and got it not working. I assume it is behause of something is wrong/different with the new Unfortunately presentenIy I don‘t have an idea for a solution.
Best regards
kDMSch

Continuing the discussion from OH 2.5 M2: no Initial load of status of knx items at startup anymore:

The same thing happens to me. In the events.log file during openHAB reboot there is no trace of particular activities except for the update from UNINITIALIZED to INITIALIZING and from INITIALIZING to OFFLINE of the devices, but not updating their values even though the sign ‘<’ is specified provided by the KNX binding.

Thanks

after setting " autoReconnectPeriod=1" to " autoReconnectPeriod=60" in the knx.things file it worked properly again. Hopefully this will help others also.

2 Likes

I solved it too, Thanks

I am having the same problem - knx stat isn’t updated on startup. There has to be an item change on knx bus to get the value. I already tried setting the autoReconnectPeriod=60 - but i am still getting no initial values. Openhab 2.4 knx worked without problems.
Here is my config - but none worked to get initialization with OpenHAB 2.5b2 knx binding:

Thing device a12 "KNX A12" @ "KNX" [ address="1.0.12", fetch=true, pingInterval=600, readInterval=240 ] {...

Thing device a12 "KNX A12" @ "KNX" [ address="1.0.12", fetch=false, pingInterval=600, readInterval=240 ] {

Can anybody help? Could you post your knx.things configuration here to help?

I think you are using a different interface for conneting knx to openhab. My connection is via IP-gateway and uses following parameters:

Bridge knx:ip:bridge [ 
    ipAddress="192.168.xxx.yyy", 
    portNumber=3671,  
    type="TUNNEL", 
    readingPause=50, 
    responseTimeout=10, 
    readRetriesLimit=3, 
    autoReconnectPeriod=60,
    localSourceAddr="0.0.0"
] {
    //AB HIER WERDEN DIE DEVICES ANGELEGT

Tried 2.5m3 and there the KNX binding is initializing items as expected. So it seems to be a bug in 2.5m2 KNX Binding.