OH 2.5.x issues with Sonos Binding - using docker

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
      Raspi 3B
    • OS: what OS is used and which version
      Rasbian + Docker; OH 2.5.4 as container
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue

I have an OH 2.5.4 running as a container with several bindings working well (e.g. KNX, MQTT, NTP, …).
I wanted to get the Sonos binding active (was active with OH 2.4) but I fail.
I’m using Paper UI. When I click “install” the Sonos binding it starts and shows the spinning wheel but never updates as installed like other bingings do - same for “uninstall”. When I reload the page it is shown with “uninstall” or “install”.
In parallel I look at the OH logs and whenever I install or uninstall the Sonos binding I experience ERROR logs from onewire binding which is running as expected. There is also an INFO log line from Modbus binding. I don’t understand the relation of these activities. A log snippet is attached.

After Sonos binding installation I go to the Inbox to discover my Sonos devices. But none is detected. This worked in my previous OH 2.4 installation and all devices have been found via Discovery. The OH container is running with “net=host”

I tried to find help with Google, but was not successfully yet. From some posts I assume it should work but I don’t know what is going wrong in my system.

Currently I don’t have further Sonos things, items, sitemaps active in my system.

Any help would be appreciated.
Thanks mobil750

  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

openhab.log (19.1 KB)

Can anybody help me on this weird issue?

It seems that a simple upgrade between 2.x versions doesn’t work correctly by just exchanging the docker image. A complete new installation with stepwise installation of required bindings and afterwards reusing the things, items, … files solved the problem.