OH 3.1 SNAPSHOT #2354 Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.console.telegesis/1.3.10

Tags: #<Tag:0x00007f43493d1a88> #<Tag:0x00007f43493d1998>

I’ve looked at the other similar posts from today and I’m wondering if they are all related. But I can’t be sure.

This shouldn’t be a Bintray issue as I’m running the latest SNAPSHOT. And the error seems to be complaining about a third party library, not an openHAB jar file. Though I don’t know if we maintain our own copies of these libraries or perhaps something has gone wrong and I am still pointed at Bintray.

If anyone has any ideas whether this is something that should go away on its own (temporary outage on some upstream server), something I’ve messed up, or a problem a developer needs to be addressed would be most welcome.

Logs:

2021-04-28 15:44:02.557 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to 'America/Denver'.
2021-04-28 15:44:02.614 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to '39.051660101889716,-104.81540679931642'.
2021-04-28 15:44:02.616 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to 'en_US'.
2021-04-28 15:44:05.713 [WARN ] [.transport.servlet.ServletController] - Can't find the request for http://argus.koshak.net:8080/rest/events/states's Observer 
2021-04-28 15:44:08.508 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-networkupstools, openhab-persistence-mapdb, openhab-binding-mail, openhab-misc-openhabcloud, openhab-binding-evohome, openhab-ui-habot, openhab-binding-network, openhab-binding-zwave, openhab-binding-zigbee, openhab-binding-shelly, openhab-binding-chromecast, openhab-binding-mqtt, openhab-persistence-rrd4j, openhab-binding-roku, openhab-binding-ipcamera, openhab-binding-openweathermap, openhab-binding-astro, openhab-binding-remoteopenhab': Error:
        Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.console.telegesis/1.3.10
2021-04-28 15:44:08.591 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist'
2021-04-28 15:44:08.987 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'mapdb.persist'
2021-04-28 15:44:11.688 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2021-04-28 15:44:13.035 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.
2021-04-28 15:44:13.783 [INFO ] [org.openhab.ui.internal.UIService   ] - Started UI on port 8080
2021-04-28 15:45:07.782 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-networkupstools, openhab-persistence-mapdb, openhab-binding-mail, openhab-misc-openhabcloud, openhab-binding-evohome, openhab-ui-habot, openhab-binding-network, openhab-binding-zwave, openhab-binding-zigbee, openhab-binding-shelly, openhab-binding-chromecast, openhab-binding-mqtt, openhab-persistence-rrd4j, openhab-binding-roku, openhab-binding-ipcamera, openhab-binding-openweathermap, openhab-binding-astro, openhab-binding-remoteopenhab': Error:
        Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.console.telegesis/1.3.10
2021-04-28 15:46:07.478 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-networkupstools, openhab-persistence-mapdb, openhab-binding-mail, openhab-misc-openhabcloud, openhab-binding-evohome, openhab-ui-habot, openhab-binding-network, openhab-binding-zwave, openhab-binding-zigbee, openhab-binding-shelly, openhab-binding-chromecast, openhab-binding-mqtt, openhab-persistence-rrd4j, openhab-binding-roku, openhab-binding-ipcamera, openhab-binding-openweathermap, openhab-binding-astro, openhab-binding-remoteopenhab': Error:
        Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.console.telegesis/1.3.10

The error just keeps repeating.

  • Platform information:
    • Hardware: ESXi 6.5 VM
    • OS: Ubuntu 20.4 running the official Docker Image of openHAB in Docker 20.10.6
    • Java Runtime Environment: Zulu Java 11
    • openHAB version: 3.1 SNAPSHOT #2354

P.S. I wonder if it make sense to bundle the add-ons in the Docker Image. Discussion is welcome.

Update: Downloading the latest addons .kar file and dropping them in the addons folder got me back up and running again. For anyone else looking for a temporary work around this is it.

Your title indicates Zigbee but you tagged zigbee2mqtt.

If it is the Zigbee binding we should probably tag Chris. He is very busy but responds when tagged.

I didn’t have my glasses on and mistakenly selected zigbee2mqtt instead of zigbee-binding. I’ve fixed the tag.

I know that Chris is very busy so I didn’t want to tag him directly unless I found out that it was really a problem with his binding and not a problem with the build in general or Artifactory or something like that.

So far there has been no responses. I’ll leave if for a little longer then tag Chris. I’ll also need to test it to make sure it’s still a problem.

He will respond. I figured it was something like that.

I think he is still in temporary housing in New Zealand looking for permanent housing. I do not envy moving internationally but I respect him for doing it, especially since he moved back to his native country.

Similar issue for me but different dependency - JDBC MariaDB:

2021-04-29 19:08:27.019 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-tr064, openhab-persistence-mapdb, openhab-binding-dwdunwetter, openhab-binding-deconz, openhab-misc-openhabcloud, openhab-binding-avmfritz, openhab-binding-pushover, openhab-binding-chromecast, openhab-binding-feed, openhab-binding-netatmo, openhab-transformation-map, openhab-binding-kodi, openhab-binding-tradfri, openhab-transformation-scale, openhab-binding-samsungtv, openhab-binding-icalendar, openhab-binding-mail, openhab-voice-googletts, openhab-persistence-jdbc-mariadb, openhab-binding-sensebox, openhab-binding-max, openhab-binding-tankerkoenig, openhab-automation-jythonscripting, openhab-ui-basic, openhab-binding-openweathermap, openhab-binding-astro, openhab-misc-metrics': Error:
	Error downloading mvn:org.mariadb.jdbc/mariadb-java-client/1.4.6

Did not find the time to dig deeper.

Additionally it looks the REST interface does not start in my environment:

image

1 Like

Just wanted to add a follow up. I’ve updated to today’s SNAPSHOT and it is showing the same error. So this doesn’t indicate a temporary problem. And given Christoph is seeing the same error for a MariaDB third party library I don’t think this is necessarily a binding specific problem.

I’m not sure where to file an issue though. Is this a problem with core or distro or somewhere else? Chris maintains the zigbee binding in a separate repo from the MariaDB add-on so I think it’s at a higher level than the individual addons. What do you think @cweitkamp?

The ZSmartSystems JAR files are available in Maven central, but I’m not sure how OH is configured.

It’s certainly not a binding issue as the binding doesn’t try to download these itself.

It’s not the binding that is failing to download - it’s independent dependencies that are failing to download here. As I said above, these are available in central, so I would have expected that OH could access them, but I’m not exactly sure how OH distro has been configured.

1 Like

I had exactly the same on 2350 when loading up today. Dropped a kar in for now to get round it

Stopped openhab and cleared cache but it still wanted to install the binding on restart (plus others in queue), where are these located so they can be removed? Did have a quick look but couldn’t find anything.

The cache file for the addons in somewhere in the userdata tree and is called addons.config Note the file extension. This is NOT addons.cfg in the CONF area.

Thanks @Bruce_Osborne, found it.
userdata/config/org/openhab/addons.config

1 Like

Stop OH before editing

1 Like

My REST interface is working again. I got it running again after removing the Metrics Service.

I have the slight feeling that the downloading issue seems to be related to the sunset of Bintray. More or less a problem of OH distro.

btw. the *.kar file helps for me too.

1 Like

Hm, that’s unfortunate. The reason for these problems is that our Artifactory no longer proxies the whole world of Maven Central (as this cause huge data transfer). We therefore need to host all our dependencies on Artifactory ourselves. Currently, everything for 3.0.2 is available there, but the milestone and snapshot builds have clearly evolved and require newer versions of libraries.
I will upload those with the M4 release today, so that the errors should go away. But we will have to think about a solution on the long run.
We explicitly didn’t configure openHAB distro to look for dependencies on Maven Central, so that we have under control, what we offer for download. But with more and more add-ons having various dependencies to Maven artifacts, this becomes more difficult. In the past when we had the clearly defined target platform that included all dependencies, it was much easier…

2 Likes

Zigbee dependency download should succeed now again.

My REST interface is working again. I got it running again after removing the Metrics Service .

@cweitkamp Was this every working for you? When I install that add-on (without any errors), my Main UI immediately disappears, so that openHAB becomes unusable. I doubt that it is related to download issues of this thread.

No, it didn’t. After fixing the missing dependency in openhab/openhab-core#2289 it looks like the REST API wasn’t starting anymore. Removing org.openhab.io.metrics it was working fine again.

MariaDB still is not working on M4:

	Error downloading mvn:org.mariadb.jdbc/mariadb-java-client/1.4.6

Uploaded dependencies for mariadb and mysql. Tested installation of all persistence add-ons successfully on M4.

2 Likes

:+1:

Thank you very much. I hope there won’t be too much missing dependencies on Artifactory and users can enjoy using this milestone now.

2 Likes

I
I just setup an new openHAB. All Links towords openHAB 2 sems to be not reachable.

Download openHAB | openHAB no download availible

also I got this isue
2021-05-04 17:58:17.188 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-transformation-javascript, openhab-transformation-regex, openhab-ui-habpanel, openhab-transformation-jsonpath, openhab-transformation-xpath, openhab-ui-restdocs, openhab-transformation-map, openhab-ui-basic, openhab-ui-classic, openhab-ui-habmin, openhab-transformation-xslt, openhab-transformation-exec, openhab-ui-paper, openhab-transformation-scale’: Error:

Error downloading mvn:org.openhab.addons.bundles/org.openhab.transform.map/[2.5.0,2.6)

If I root the site in a Browser I got the message that this site is not reacheable.

Many Thanks
Maik

What version of OH are you trying to install? The subject of this thread is 3.1 SNAPSHOT 2354 which has been replaced with a newer version.

What method are you using to install?