OH 3.3 - openhab commands sometime take minutes until they're triggered (might be shelly binding?)

  • Platform information: Raspberry Pi 4 Model B Rev 1.4

    • Hardware: _CPUArchitecture/2 GB RAM/16 GB storage
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment: openjdk version “11.0.10” 2021-01-19 LTS
    • openHAB version: 3.3.0 Release
  • Issue of the topic:

I am running Openhab 3 for roughly a year new on a rasperry, mainly to control shelly devices, deconz (conbee II stick), echo devices plus serveral other bindings. Since some days I run into an issue where the commands from openhab aren’t executed/triggered or they are with a delay from up to some minutes.
A restart always resolves the issue for maximum one day.

Let me give you some examples:
a.) I want to turn on bathroom light with a shelly switch. The events.log successfully and immediately recognizes the trigger event (short pressed shelly button #1…). The log also shows immediately that the command to turn on the light (over a shelly dimmer) was triggered and the item state shows that correclty within openhab gui.
But the shelly device didn’t receive that command, the light stays off.

b) I want to turn on a yeelight wifi light by pressing a switch connected to another shelly. The light turned on around 5 minutes after the switch was pressed.

I am using the official 3.3. shelly binding with Auto-CoIoT setting.

I tried to remove and reinstall the binding which didn’t help.
I also tried cleaning openhab cache.
Checking logs from events and openhap, I am getting nothing helpful. Events are recognized in time, openhab log shows some information but no warnings.

The affected lights, either connected over shelly or yeelight can always be turned on/off properly over their native apps/remote control.

I don’t know what things best to try next. I’d still say I am more a beginner than experienced openhab user. Mainly having some simple rules setup, but not really aware of how openhab is running in the background.

Appreciate any hints what to try and start, I’ll feedback to your comments asap.

thanks a lot,

please be detailed explaining your issue

  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Update // seems to be a shelly specific issue.I’ll head over and ask there.

Might be OH 3.3 causes some issues. Other interaction within Openhab seems to work.

Thanks anyway :slight_smile: