OH 3 Broadlink

Hi guys, I set up my oh 3 and everything worked great, just about configure the broadlink, I used to use this git owned by ‘fbacker’ on OH 2.4 (https://github.com/fbacker/broadlink-mqtt-bridge)
It’s worked really good I’ve recorded about 200 commands. I tried to install it on OH 3 (Installed MQTT Biding, Mosquitto, and I have node version of 14.)
I tried to install manually, and automatic , nothing worked.
I can’t reach to IP:3000, only to the LOG IP:3001. (also opened a case in the git for Fbacker still waiting for answer)
Does anyone know why I can’t install the git of Fbacker? Or if someone have another idea for using Broaldlink RM Mini 3 with new Openhab 3.

My hardware:
RPI 4 , Openhab 3, Broadlink RM Mini 3, already installed (if metter) Mqtt binding.

Thanks for any help.

Did you try:

This is the case I have opened, the one that helps there is using Docker, I tried to change the default.json to as well . Nothing worked.

what is the output of
sudo netstat -tulpn | grep 300

This should return all rows that show lines with 300 in it.
That means it should show information about listening port 3000 as well as port 3001.

This is the output I got using Putty:

tcp 0 0* LISTEN 1621/node

that means it is indeed only listening on port 3001.
does the software offer any log messages or possibility to generate debugging messages ?

Im not sure…Its more like a folder that containes files I am not really fimilliar. I think I saw a few files that can provide some debuggins issue. At that momment I away from homr but will try it asap.

If you have any other info I will like to hear. Thank you

In github issue tracker there is a second one that is about the same problem. It also reports that the other suggestion did not work and there is an other suggestion: https://github.com/fbacker/broadlink-mqtt-bridge/issues/54

Thank you , this issue case solved my problem.
Credit to **Astral0

The problem is localised in commit [cabd581](https://github.com/fbacker/broadlink-mqtt-bridge/commit/cabd581072247b03dee2fee9ebda53aba4d5ebc4)

And the solution is to revert the line 302 of file src/web.js to its previous state :

this.server.listen(config.settings.gui.port, this.host, () => {

replace by :
this.server.listen(config.settings.gui.port, () => {

That worked for me. thank you as well @Wolfgang_S

I am now facing at new problem, how to Publish MQTT Actions in Openhab 3.
To be honest I prefer to work with VS Code only, I route VS to my Openhab/conf, and now i’ve access in VS Code to OH files and can create files on [Item+Rules+Sitemap] Folders. but I am not sure how do I connect between what I’ve created to Openhab3 new interface.

As well I am not sure I can use the same language I used to .
For example for rule code I want to use.
“When Item changed to ON then {CODE} END”
And the I probebly need to figure out how to publish in this case MQTT Actions.
In OH 2.4, I used (MQTT action binding) to be able to "Publish(“mosquitto”, “MYPATH” , “DEVICE”)

Does anyone can guide me to some toutorial? Docs? Or can help me by any information he can provide I will be thankful !
Thanks alot.

1 Like