OH 3 with OH2.4 Cloud - Message when logging in

Hi All

When using a 2.4 instance, you get a different message and by pressing the hyperlink, it directs you to the various UI;s

When using 3.0 as the client, you get this:

You are using OpenHAB 1.x. To remotely access your openHAB’s web interface go to https://server.x.x.x:443/openhab.app?sitemap=yoursitemapname

Any reason why this occurs? There is no site map thats been setup on OH3.0, Id expect it to go to the OH3 overview page

Thanks!

Do you mean this message when you log into myopenhab.org via a web browser?

image

I’m on OH3, and when I click the link, it takes me to my OH3 overview page as expected. So it sounds like your system is mid-identifying itself. I’m using Chrome on a Windows PC.

Thats right Russ, thats the message i’d expect. I’m using OH2.4 Cloud self hosted though so id be keen to know if something has changed.

Ah, I didn’t realize you were talking about a self-hosted cloud. I recall some discussion about the OH3 cloud being able to identify the client system, but damned if I can find it. May have been on Github.

On the myopenhab cloud, when I click the link I go to https://home.myopenhab.org/. I wonder if there’s an equivalent subdomain that you can directly access on your cloud? Not that this answers your question about anything changing…

OH2.4 Cloud is looking for openhab.app, yet if I open the OH3 site map its http://192.168.0.98:8080/basicui/app?sitemap=Home

Perhaps you need to be running the latest cloud code. I believe there were some changes for OH3.

1 Like

that is correct.

Fair enough, the upgrade process is a pain but thats what I’ll do!

1 Like