OH 4.0.3 Docker Z-wave stick not working

So, I upgraded to OH4.0.3 today, using docker on my RPi. Strangely enough my Z-wave devices stopped working, because the controller isn’t recognized by the binding anymore. I did nothing other than before, starting the container with the --device=/dev/ttyUSB0 and ACM0 arguments. But now the controller shows “ERROR:BRIDGE” next to it in the things list. Removing and re-adding doesn’t work.
Docker log shows:
Exception in thread “ZWaveReceiveInputThread” java.lang.NoSuchMethodError: ‘void org.openhab.core.library.types.DecimalType.(long)’
at org.openhab.binding.zwave.handler.ZWaveSerialHandler$ZWaveReceiveThread.run(ZWaveSerialHandler.java:304)

Any suggestions, am I missing something here? Thanks

Had the same problem in the same setting.

Have you checked whether the address of the stick remained the same? In my case it changed for no reason.

Not sure what you mean with “address”? I checked in dmesg on the pi and it showed an ACM device after replugging the usb. So I selected /dev/ttyACM0 as the source for the serial device in the controller “thing”.

This is runtime error, it means that zwave handler was compiled against other version of OH core. It is unlikely to happen under normal conditions.
Make sure you clear cache and do not have any kar pulled over addons folder.

Thanks for you suggestion Lukasz, I’ve deleted the cache and tmp folder, deleted the container and image and restarted the whole thing, but still I get the same error in the logs

I’ve searched a bit further and I discovered a z-wave .jar file in the addons folder. I’ve removed it and cache / temp folders again, cleaned up docker again and restarted the image. Now it’s working. Thanks for leading me to the solution!