OH 4.1.0 on Docker is not getting any events from CCU2 or Raspberrymatic

Hi OH community,

started my update project OH2 => OH4 (complete new setup)
Receiving event on OH2 are working, but on OH4 (docker) getting no events.

Was able to connect to CCU and see all my things in inbox.
CCU and things are online and can see all items (e.g. Power, Current, State)
Also got one-time values from all items, but the values will never be updated.
e.g. If I switch off my socket manually (on the device) RaspberryMatic is displaying the correct state but not OH4.

Did somebody has an idea, why OH is not getting any events from Homematic?

Thanks and regards

Sebastian

I assume there‘s nothing unusually strange in the logs? I have the same setting (OH 4.1 on Docker, CCU2), and things are running like normal.

That’s looks a little bit strange: (are the Raspberrymatic logs, but have the same issue with CCU2)

Jan  4 22:23:42 homematic-raspi user.err rfd: XmlRpc transport error
Jan  4 22:23:50 homematic-raspi user.err rfd: XmlRpc transport error calling system.listMethods({"f427488b-4738-4f5a-811e-9ae743ad6c5c"}) on http://raspberrypi.local:9127/RPC2:
Jan  4 22:23:50 homematic-raspi user.err rfd: XmlRpc transport error calling listDevices({"f427488b-4738-4f5a-811e-9ae743ad6c5c"}) on http://raspberrypi.local:9127/RPC2:

Whenever I had problems with my CCU2 and OH, I stubled upon a post from @MHerbst who addressed this problem in a previous post. In case this log entry has not been covered before (I assume you‘ve done done search already) if you‘re lucky he has a chance to look at your logs.

Hi all,

it seems that my problem was a port problem, wenn using portainer.

Since I’m using Podman instead of Docker everything is running smoothly.
(I assume it has something to do with the Portainer port 9000)

Sorry I didn’t made further and deeper analysis.

Thanks and regards

Sebastian