OH doesn't want to read topics from MQTT server


It seems I have one very strange problem. After some rules editing, I see that my openhab instance doesn’t want to communicate with my mosquitto server. It says that there are no errors. Mosquitto also says that OpenHab connected successfully. Mosquitto also works because I’m able to connect with any MQTT client and read all topic. But OpenHab thinks that there are entirely no updates in the topics (but there are!). Restarted OH2 few times. No changes. I really don’t want to reboot the whole PC. Could you help me somehow?

The most likely problem is the item config is wrong somehow.

Solved the issue. Something like a phantom bug. Configs were okay. I didn’t touch them at all. But changed MQTT id one more time it issue was gone.

Unfortunately, I need to re-open the current topic. Got the same behavior. Settings are GOOD! Everything worked before openhab2 restart. After the restart, I see that OpenHab connected to mosquitto, but it doesn’t read any values.

I see different topics with the same issue. For example

So… seems this is common thing. Is there any kind of workaround? I’m using OpenHab 2.1 right now

People who have run into issues with MQTT after upgrading to 2.2 have worked around some of them by uninstalling and reinstalling the MQTT Action and Binding.