OH hue emulation and alexa on different subnets

I started to integrate an echo dot with OH (2.4 release) via the Hue emulation. For security reasons I have many of my IOT devices (including echo) on a separate VLAN (192.168.4.x) while my OH lives on the main segment (192.168.5.x) Router is a Draytek 2925.
The routing table on the OH server was configured to forward port 80 to 8080.
For initial testing I configured the router to connect both VLANS to each other. Echo did not detect any devices.
Then for a 2nd test I registered the echo on the main network segment, after which I was able to find devices and use them. then I moved the echo to the IOT segment -> still able to control the devices, but seem not able to discover new ones.

I suppose the following happens, but maybe somebody can confirm it:

  • When the echo dot is searching for devices it scans all ip addresses in its own subnet for a Hue bridge on port 80. This will of course never reach the port 80 on the other subnet.
  • Once a device is configured, the OH IP address is stored inside the echo for the device. The echo uses the gateway for control, hence it still works when on another subnet.
    Can somebody confirm this assumption of discovery is correct ?

This leads me to the next question. I expected to be able to add a rule in the router which maps port 80 of to port 8080. This seems however not possible. Any other suggestions how to do this ?

When I ran into problems I tried to test the hue emulation by using the test url:
After I set the hue emulation into pairing mode, the result was “not authorized”

Is this URL supposed to be working ? The bridge is supposed to work, because I added devices yesterday ?

Any suggestions or help would be appreciated.

Same challenge here, did you come to a solution?