OH just stopped working - please help


yesterday I ran into a strange problem.
The log files after several days were huge and I deleted them (all in /var/log/openhab/) and restarted OH.
Unfortunately I was not able to connect anymore.
After a complete shutdown and several reboots, the raspberry pi 2 B comes up and according to /etc/init.d/openhab status it’s running. However, the logfiles are completely empty (size 0), but are obviously generated during startup.
Even in debug log mode there is no information.
The weird thing is: I did not change anything in the last days.

Might this be a HW related issue (SD-card?)

HABmin doesn’t show “online” either, but generates entries in request.log

Is there any option to run openhab in debug mode, so that I can see at least some information on the console output?
According to some docs there should be a start_debug.sh which is obviously not existent on raspbian.
Any hint how to troubleshoot this issue?

I removed --background from the start script, but it doesn’t really help.
The only thing I get now is:
sudo /etc/init.d/openhab start
[…] Starting openHAB server: openhabListening for transport dt_socket at address: 8001

nothing else…

Take a look here:
Continuing the discussion from Openhab Debugging started as service?:

If that doesn’t work edit your logback.xml and replace all occurrences of

Thanks for your help, @sihui.
However, switching to debug mode (changing debug=no to debug=yes in logback.xml) is not the issue.

The problem is, that there is no logging at all !
All log files have size 0

[quote=“NCO, post:4, topic:7470, full:true”]
The problem is, that there is no logging at all ![/quote]

Yes, I read that, but I have no clue :slightly_smiling:

Actually I was referring to the mentioned tail command …

What I would do in that case: download the latest OH, get the logback.xml, copy it to /etc/openhab, make sure it can be read by the openhab user (for testing you could chmod it to 777) and restart openhab.

Thanks for your help anyway :wink:

I tried your suggestion, but it did not change anything…

Any other suggestion to get some more information what’s happening?

I just rolled back to an old sd-card image (OH 1.71 with a very old config) and started to update / upgrade it step by step.
So far it works without problems and I am almost done with items, sitemap, mappings and rules.

However on the first try I first updated OH to 1.8.1 and copied the full OH configuration into the main OH directory on a running OH instance.
The resulted into a messed-up system again.

So, is it possible that copying multiple files (e.g. rules, items, sitemaps) at once will result in file corruption?

I do that all the time (although after stopping OH) when upgrading and have had no problems with that.

But regarding backups: take a look at http://www.linux-tips-and-tricks.de/en/backup/
With the help of a cron job you are able to perform incremental backups with hardlinks (rsync) and you will not have “an old sd-card image” anymore. You even can do full dd images if you prefer that … :grin:

hmmm, weird.
But thanks for the tipp - I will try it out to roll back easier :slight_smile: