OH on Synology getting slower and stopped now

Hello, everybody,

lately I noticed that OH on my Synology 215j was getting slower and slower and now nothing works at all. Usually restarting the Synology helped.
After a complete restart, the log files indicate that everything is ok (rules and items loaded), but OH is completely refusing to work as of today.
I can’t see anything under “Control” in PaperIU, for example. I can’t see or even control a single device.

OH 2.5
Java 1.8.0_241

Do you have any idea what I can change?

Thank you so much!

Translated with www.DeepL.com/Translator (free version)

Restart OH a few more times and if that does not help then clean the cache and tmp files then do two restarts.

With that information only, no.
Except to move off your NAS.
OH uses a lot of memory, running on a small NAS is definitely no good idea.

Thanks so far…
It is a small NAS, but OH used to run…
What specific information is needed?

Under openhab/userdata/cache I have a directory “org.eclipse.osgi” with a lot subdirectories named with numbers 1 to 230, a dir named .manager and a file called “framework.info.120”.

Shall I delete them all?


Do you have a back up?

Do you run CalDav on you Synology to sync your calendars / reminders between your iPhone and the Synology ? A colleague of mine had a similar problem not running OH on his Synology. But since an update last year ( ? ) his Synology was always occupying more and more memory. Last weekend he hoepfully fixed it. Root cause is a change in the calendar format done by Apple.
You may have a look to this: https://www.synology-forum.de/showthread.html?102973-WebDAV-CalDAV-CPU-und-RAM-Auslastung/page2 ( in german language )

FWIW, I wouldn’t run on ANY NAS.
One of the two main problems of doing so is that there’s very few people to have the same setup thus very little who can (potentially) help with your problems.
Official docs also recommend to use a dedicated system.

To begin with, read
How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Good news - it woks in the moment.

What I wonder was the fact, that the page Control in PaperUI does not load. A week before I could see the control panels of all things. If I search for new things, the inbox became fully crowded as expected, but no control page…

So I unistalled all (just two…) bindings, installed and configure them again.
After stopping and restarting the OH service on the Synology all OH functions are up and running again.

Thank you so far - I would not say the issue is solved, because I could not see any root cause.
Let´s see how the system behaviours in the next time.

Thanks so far!!!

just for the sake of completeness,

  • multiple restarts had no effect
  • same with deleting cache directory (same as old one was rebuild after restart)
  • no DAV services running on the machine

But thanks a lot for looking at my issue!!