OH started to talk to me

  • Platform information:
    • Hardware: RPI 2
    • OS: openhabian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.4
  • Issue of the topic: please be detailed explaining your issue

I’ve installed VoiceRSS and added to one lighting rule the “say” command. Works nicely.
Shortly after, whenever I open the door the system says “Door is open” even though I didn’t configure anything regarding voice and the door sensor.

Is there some automatic setting to speak whenever the item state changes?
How do I disable?

1 Like

To get a better understanding of what you’ve done, could you provide both your .items file and .rules file. There is no default one size fits all approach to using VoiceRSS. What I suspect you’ve done is setup something incorrect. How you think it works may not be how it actually works, I’ve lost count the amount of times this has caused me issues.

Are you by any chance using HABPanel? This UI has a setting on which it notifies about state changes of a selected item via voice notifications.

Disabled the voice support on my HABPanel, but still the door “talks” to me

My only rule is:
rule “SaySomething received command”
Item SaySomething received command ON
say(“Hello”, “voicerss:enUS”, “chromecast:chromecast:5c6b93230fc39dba32da63e69ee84bd7”)

Switch SaySomething “Say”

Door item:
Contact Contact_FrontDoor “Front Door” {channel=“mihome:sensor_magnet:158d0002c62f3f:isOpen”}

In order to make sure where it is coming from you need to know from which hardware the sound is coming from. Only a specific device, like a smartphone or tablet ( they could use their own voice).
Is the sound played by a device that is a known audio Sink for openhab? Is this case if disabling the VoiceRSS stops the sound it is definitely from openhab.

The sound is coming from my Google Mini that is indeed marked for audio sink.
I could disable VoiceRSS entirely but that won’t allow me to use text-to-voice in the future.

I was just trying to help finding the cause. If the sound would not stop while voicerss is disabled you could search somewhere else.
If it is openhab somehow, you should be able to see some entries in the log.
Can’t tell if the Google Mini has the ability to report such changes on its own.

I had a rule in the Paper UI rule generator that I created long before I installed a VoiceRSS. This is what started “talking”. Have since worked with rule files only so totally forgot about it.
Feeling stupid :flushed: