OH_v2-1 Installation ended with errors

Dear Community,

I was able to install Eclipse openHAB like described here: http://docs.openhab.org/developers/development/ide.html I installed it on Windows 10, MacOS and Linux Ubuntu.

Unfortunately there were some errors on Windows and Linux - what could be the reason for these?

See the attached screenshot for further information.

Thanks in advance for some hints.


Linux (none of the subprojects got created):

I tried to install openHAB-2.1 on another Linux box. I got some errors too!? I am wondering on what OS your openHAB 2.x installation runs?

Can anybody please verify if the current eclipse-installer-openHAB-2.1-version works on Linux or Windows ? Thanks in advance. Currently I tried to install it on three different boxes without any success. As mentioned before on my Mac there were no problems at all.

I installed Eclipse on Win 10 with no obvious issues. Used it to create rules etc on an openHAB 2.1 install on the same machine. Tested by binding routers time change to invoking chromecast on tv with no problems. RPi install however has got me beat…

The reason is that the IDE checks out the latest master, so there is always the risk that some project shows some error - it is simply living code. All the NullAnnotation errors from your screenshot should have been solved already, for two of the others I have just created
fixed compilation error in IDE by kaikreuzer · Pull Request #5324 · openhab/openhab1-addons · GitHub and The HueLightHandlerOSGiTest uses this class, which results in an erro… by kaikreuzer · Pull Request #4413 · eclipse-archived/smarthome · GitHub.

Note that such errors do not cause any issue, though. If you do not plan to work on a specific project that has an error, you can fully ignore it (e.g. by closing the project in the workspace). It actually is fine to have NO projects in the workspace at all, the launch configuration should work just fine in any case.

Your second screenshot from Linux shows another more severe issue, though: You seem to have OpenJDK 9 installed on that machine. For the openHAB IDE, you should definitely use OracleJDK 8 instead!

Hope this helps!

Thanks a lot! Now the openHAB-IDE works on Mac, Windows and Linux.