OH2.2 and 2.3 SNAPSHOT continuously resetting after 1st installation

This is an known issue starting in distro 1012 but it seemed to be solved in issue #519


The symptoms are that after the first startup after installation, the following startups fail

14:18:37.146 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Stopped HABPanel
14:18:37.150 [INFO ] [i.dashboard.internal.DashboardService] - Stopped dashboard

I thought that with the ralease of OH2.2 this should be solved, but instead I keep having the same issue. It is only solved if I go back to 2.1
By the way, I am not using any local addons.kar, I use the remote repository.

What could be the problem?

  • Platform information:
    • OS: OSX
    • openHAB version: 2.2 and 2.3 snapshot

I tried to make a clean installation from zero, but I am still getting the same error?
Am I the only one? Why OH stops all the time?

openhab> log:tail
20:02:08.470 [INFO ] [der.internal.HomeBuilderDashboardTile] - Started Home Builder at /homebuilder
20:02:08.652 [WARN ] [rg.eclipse.smarthome.core.net.NetUtil] - Found multiple local interfaces - ignoring 192.168.1.100
20:02:08.655 [WARN ] [rg.eclipse.smarthome.core.net.NetUtil] - Found multiple local interfaces - ignoring 192.168.1.100
20:02:08.666 [INFO ] [i.dashboard.internal.DashboardService] - Started dashboard at http://192.168.1.107:8080
20:02:08.666 [INFO ] [i.dashboard.internal.DashboardService] - Started dashboard at https://192.168.1.107:8443
20:02:10.278 [INFO ] [rthome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
20:02:10.790 [INFO ] [.basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
20:02:10.806 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
20:02:10.829 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
20:02:13.004 [INFO ] [.basic.internal.servlet.WebAppServlet] - Stopped Basic UI
20:02:38.795 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Stopped Paper UI
20:02:38.801 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Stopped HABPanel
20:02:38.805 [INFO ] [der.internal.HomeBuilderDashboardTile] - Stopped Home Builder
20:02:38.808 [INFO ] [i.dashboard.internal.DashboardService] - Stopped dashboard
Connection to localhost closed by remote host.
Connection to localhost closed.

I’m off topic, it’s not a solution to your problem, just an observation. Do you have 2 network interfaces on your computer? If so, why are they on the same subnet 192.168.1.0/24?

Yeah, I didn’t realized ethernet and wifi were on. I just disabled wifi connection. Thanks for that

But that is not the issue. I still get the same problem