OH2.3 KNX - Can not write to the bus

binding
knx2
Tags: #<Tag:0x00007fe052873f40> #<Tag:0x00007fe052873e00>

(Frank Weismantel) #1

I have an KNX router running on a Raspberry PI3 B+. I can communicate with ETS software and other smart home apps like the home app withe home bridge knxd or the ayControl are working without any problems.

I used as binding in OH the following configuration in knx.things:

Bridge knx:ip:bridge [ 
type="ROUTER",
ipAddress= "224.0.23.12",
portNumber=3761, 
localIp="192.168.251.30",   
localSourceAddr="1.0.201",     
ignorelocalevents=true

]
{
Thing device switch {
Type switch : scale_interrato “Switch” [ ga=“1.001:0/2/0+<0/2/0” ]
}
}

As I can see in the log of OH, the connection to the KNX router is established and it looks like that the commands where send over the bus:

23:35:07.351 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:bridge:switch’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
23:35:07.401 [DEBUG] [calimero.link.224.0.23.12:3671 ] - send (wait for confirmation) 1.0.201->0/2/0 L_Data.ind, low priority hop count 6, tpdu 00 00
23:35:07.402 [TRACE] [ip.KNXnet/IP Routing 224.0.23.12:3671] - add to multicast loopback frame buffer: 1.0.201->0/2/0 L_Data.ind, low priority hop count 6, tpdu 00 00
23:35:07.405 [TRACE] [ip.KNXnet/IP Routing 224.0.23.12:3671] - sending cEMI frame seq 0, NonBlocking, attempt 1 (channel 0) 06 10 05 30 00 11 29 00 bc e0 10 c9 02 00 01 00 00
23:35:07.405 [TRACE] [calimero.link.224.0.23.12:3671 ] - send 1.0.201->0/2/0 succeeded
23:35:07.406 [TRACE] [mero.process.process 224.0.23.12:3671] - sent group read request to 0/2/0
23:35:10.998 [INFO ] [org.quartz.core.QuartzScheduler ] - Scheduler openHAB-job-scheduler_$_NON_CLUSTERED started.
23:35:17.410 [INFO ] [mero.process.process 224.0.23.12:3671] - timeout waiting for group read response from 0/2/0
23:35:17.412 [DEBUG] [knx.internal.client.AbstractKNXClient] - Could not read value for datapoint 0/2/0: timeout waiting for group read response from 0/2/0. Going to retry.

But on the ETS Bus Monitor, I see no action for this read command.

Can anybody help ?


(Angelos) #2

Is your KNXnet/IP Router set to filter or route the telegrams?

Try to set localSourceAddr to 0.0.0 and try again

Also: How to use code fences


(Frank Weismantel) #3

After setting the locaSourceAddr to 0.0.0, it is getting more worse. Before OH was receiving the datagrams, which were triggered a device. When I was turning on/off the light with my ight switch at the wall, OH was
seeing them and on my GUI, the lamp switches from ON to OFF and the other way round.

Now OH does not receive any more this triggered datagrams


(Angelos) #4

go back to your original IA (Individual Address) for the OH2 host.

Make sure that this one (1.0.201) is free on your KNX Bus

Questions:
What is the IA of your KNXnet/IP Router?
Is this Router configured to filter or to route telegrams? (check both directions)


(Frank Weismantel) #5

The router is configured to route the telegrams and yes the address 1.0.201 is free


(Frank Weismantel) #6

I have still the problem, that I can only receive KNX telegrams from the bus, but I can not write anything to the bus. I have now limited the number of clients on the KNXD to 1, so that only one
is in use. Here is the configuration file of the knxd:

[main]
addr = 15.15.254
client-addrs = 15.15.200:1
connections = server,B.tpuarts
systemd = systemd

[B.tpuarts]
device = /dev/knx
driver = tpuart

[server]
server = ets_router
discover = true
debug = debug-server
router = router
tunnel = tunnel

[debug-server]
name = mcast:knxd

[router]
filters = A.pace

[A.pace]
delay = 50
filter = pace

[tunnel]
filters = log

Has anybody an idea, why the KNX Binding is not writing anything on the bus?


(Angelos) #7

based on the 2 statements above: your knxd config is problematic

check: https://groups.google.com/forum/#!forum/knxd for additional support


(Frank Weismantel) #8

Why should the config of the KNXD be problematic?
ETS5 is working without any problems. Other tools like
knx for Homebridge or ayControl are working. Only
the OH2 KNX Binding make problems


(Angelos) #9

i explained why already

in addition: a) other endpoints most likely are using unicast & b) in multicasting, IAs and other parameters need properly configured options to work… something that I don’t see in your knxd


(Frank Weismantel) #10

So you thing it is the configuration if the KNXD.

I just was doing test and using Wireshark to capture the traffic on the network.
Using ETS or other apps then OH produce traffic on the lan interface. When I
try to switch on/off the light, I can see no traffic at all on the network.

So it can not be the KNX configuration why OH is not working.


(Angelos) #11

good luck!


(Frank Weismantel) #12

It is solved. It has nothing to do with the KNXD. It was the firewall settings.