OH2.3 Z-wave dev binding with fgr222: no lamella channel


I’m trying to get a Fibaro Roller Shutter 2 (fgr222) working with venetian blinds control.
I’ve already installed a quite recent dev build of the z-wave binding:
208 │ Active │ 80 │ │ ZWave Binding
Important settings:
parameter 3 : blind position via Fibar command
parameter 10 : Venetian Blind Mode, with positioning

Calibration was done and I’ve even tried setting to toggle switches (even though I’ve got momentary switches), resetting a few times addionally.

Blinds control works both with Rollershutter and also Dimmer configuration.
Nevertheless, I don’t see the blinds_lamella channel in Paper UI or Habmin.

I’m not an OH professional, but I assumed that I should be able to see the blinds_lamella channel in the UI and link that to a dimmer item, or am I wrong?

Any help would be very much appreciated. I can also provide the node xml, if that is of any help (unfortunately, I can’t upload attachments as a new user…).

Thanks a lot!
Best regards

It’s there:

You may need to delete the thing and readd it again.

Well, it’s there for you :wink: .

This channel is linked to the manufacturer proprietary command class and this is only in the development version at the moment. I hope we will merge this if there are no further issues with the dead node feature in the next week or two.

Alternatively, you can get it from this thread -:

1 Like

Upps … did not notice he is on the snapshot … :sunglasses:

1 Like

Actually, my bad - he’s on the dev, so you are right - it’s there :sunglasses:

LOL. Too early in the morning and I only had one coffee yet :rofl:

1 Like


Thanks for the quick reply.
I tried deleting and re-adding the item, but still: I only see these channels:

node4.xml (13.0 KB)

I’ve attached the node xml, maybe that can help. I don’t know if that’s a problem, but what I noticed is that there is a command class called ‘MANUFACTURER_PROPRIETARY’ in the section ‘nodeInformationFrame’, but below, there is no entry with command class ‘MANUFACTURER_PROPRIETARY’… (?)

If there’s anything I can try, please let me know.

Thanks again and best regards

I’m not sure anymore which version you are really running:

the current development version is from June, 4th. It is only build every couple of days, so it is very unlikely that there was a version with a date June, 3rd.

Make sure you are running a development version of the binding from this post.
You cannot use a snapshot or stable version to make it work.

Correct - I keep a history and there wasn’t one on this date.

Hello all

Well, you were right. I’m not sure myself where I got the binding from - I thought ‘newer is better’ (newer being a later version number, not date).
But I was proven wrong: the one you pointed me to really works!

Thanks a lot for your help and keep up the great work!

Best regards