OH2.4.0 with KNX2.4.0 - DPT17.001 and 7.005 with number type issue

Hi folks,

I’m trying to migrate my config from OH2.2 to 2.4 and I’m facing some trouble.
I try to get/set 2 scene numbers and a time value from KNX bus and to print them to a sitemap.
Unfortunately, what was working in OH2.2 seems not working any more and I don’t understand what I could make wrong. Could someone help me to solve this issue ?

my thing:

Thing device MaicoWS320KB_KSM_KNX "VMC" @ "KNX" [ address="0.0.46", fetch=false, pingInterval=300, readInterval=3600 ]
        Type number        : FctMode                    "Mode de fonctionnement"                [ ga="17.001:6/0/240+<6/1/240" ] // nok
        Type switch        : Season                     "Saison"                                [ ga="6/0/241+<6/1/241" ] // ok
        Type number        : VentilationLvl             "Niveau de Ventilation"                 [ ga="17.001:6/0/242+<6/1/242" ] // nok
        Type switch        : InterVent                  "Ventilation par à-coup"                [ ga="6/0/243+<6/1/243" ] // ok
        Type number        : InterRemainTime            "Tps résiduel Vent. par à-coup"         [ ga="7.005:<6/2/240" ] // ok
        Type number        : InterDuration              "Durée Vent. par à-coup"                [ ga="7.005:6/2/242+<6/2/241" ] // nok

my items

/* Ventilation */
Number    FctMode                   "Mode de fonctionnement [%d]"                   <myswitch>              (gVentilation)    ["Scene"]         { channel="knx:device:EIBMarktKNXIP730:MaicoWS320KB_KSM_KNX:FctMode" }
Switch    Season                    "Saison"                                        <myseason>              (gVentilation)    ["Switchable"]    { channel="knx:device:EIBMarktKNXIP730:MaicoWS320KB_KSM_KNX:Season" }
Number    VentilationLvl            "Niveau de Ventilation [%d]"                    <myswitch>              (gVentilation)    ["Scene"]         { channel="knx:device:EIBMarktKNXIP730:MaicoWS320KB_KSM_KNX:VentilationLvl" }
Switch    IntermittentVentilation   "Ventilation par à-coup [%s]"                   <switch>                (gVentilation)    ["Switchable"]    { channel="knx:device:EIBMarktKNXIP730:MaicoWS320KB_KSM_KNX:InterVent" }
Number    InterVentRemainTime       "Tps résiduel Vent. par à-coup [%d s]"          <time>                  (gVentilation)                      { channel="knx:device:EIBMarktKNXIP730:MaicoWS320KB_KSM_KNX:InterRemainTime" }
Number    InterVentDuration         "Durée Vent. par à-coup [%d s]"                 <time>                  (gVentilation)                      { channel="knx:device:EIBMarktKNXIP730:MaicoWS320KB_KSM_KNX:InterDuration" }

my sitemap

sitemap ventilation label="Ventilation" {
    Frame label="Base" {
        Selection   item=FctMode                                        mappings=[0="Arrêt", 1="Manuel", 2="Auto Tps", 3="Auto Dtct", 4="Eco in", 5="Eco out"]
        Selection   item=Season                                         mappings=[OFF="Hiver", ON="Eté"]
        Selection   item=VentilationLvl                                 mappings=[0="Arrêt", 1="Prot c/ hum", 2="Réduite", 3="Nominale", 4="Intensive"]
        Selection   item=IntermittentVentilation                        mappings=[OFF="Off", ON="On"]
        Text        item=InterVentRemainTime
        Setpoint    item=InterVentDuration                              minValue=300 maxValue=5400 step=60
        Text        item=InterVentDuration

And this is what I get (desperately empty):

Hi @SyntaxError-404,

I was struggeling with the same issues and have partly a solution for you: simply change your mappings to float values as follows:

Selection item=KWL_Betriebsart label="KWL Betriebsart ändern"	icon="settings" mappings=[0.0="Aus",1.0="Mauell", 2.0="Auto-Zeit", 3.0="Auto-Sensor", 4.0="ECO-Zuluft", 5.0="ECO-Abluft"]
Selection item=KWL_Jahreszeit label="KWL Jahreszeit ändern" icon="climate" mappings=[0="Winter",1="Sommer"]
Selection item=KWL_Lueftungsstufe label="KWL Lüftungsstufe ändern" icon="fan" mappings=[0.0="Aus",1.0="Feuchteschutz", 2.0="Reduzierte Lüftung", 3.0="Nennlüftung", 4.0="Intensivlüftung"]

But I still have problems with the “time” part which is called at your items “InterVentRemainTime” and “InterVentDuration”. I still do not see the values as shown in your BasicUI. Do you have a solution for me?


Hi @shotte,

Sorry for replying very late, I missed the notification. Nonetheless thank you for you contribution.
Indeed your solution worked, I tried the same at some point. But finally I downloaded a new firmware from Maïco and all works better now. You can find it here: Application and firmware.

Concerning the time part, which model do you own ? These inputs/outputs come from the KNX objects of the Maïco machine you can find here:

KNX object list (https://www.maico-ventilatoren.com/en/service/downloads).

Openhab allows me to activate the “intermittent ventilation” at the maximum value after someone activate detectors in the toilets or in the bathroom for instance. It is not a crucial function and it is far easier and cheaper to implement it with Openhab than directly with KNX. I just have to write the correct rule I want to apply and it’s it. That’s really convenient.

If you want me to clarify anything just ask. :wink: