OH2.4 issues

I have been running a rpi2 with openhab 2 on a RPI 2 for since october 2019 in a flat I rent out. Today it ofcourse went down :wink: As usual right before Christmas life is busy… A reboot made it start again, however it super slow, logging in with SSH takes forever…

Im unsure what kind of upgrade I should do now to get it to run, I do not have the time now for swapping over to OH4, after xmas i will swap hardware to RPI4 and to OH4 but not now…

Any help what to do in the openhabian-config would be ighly appreciated

Maybe your SD card is dying…

Maybe…

[21:58:32] openhabian@oh2:~$ sudo systemctl status openhab2.service
[sudo] password for openhabian:
● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2023-12-10 21:58:32 CET; 21min ago
     Docs: https://www.openhab.org/docs/
           https://community.openhab.org
  Process: 997 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=0/SUCCESS)
 Main PID: 1283 (java)
   CGroup: /system.slice/openhab2.service
           └─1283 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.userd

Dec 10 21:58:32 oh2 systemd[1]: Started openHAB 2 - empowering the smart home.

It seems now that the OH server is running however i can not reach the sitemap or frontail…

the command

sudo netstat -tulpe

should show programs that have a port open. So it should show port for frontail and openhab.

In case of problems you may check the openhab.log content and/or

sudo journalctl -u openhab