OH2.4 KNX2 multiple things definition

Hello,
I would like to poll different knx items at different time so I thought I could setup something like that:

THINGS file

Bridge knx:ip:bridge [
ipAddress=“192.168.0.10”,
portNumber=3671,
localIp=“0.0.0.0”,
type=“TUNNEL”,
readingPause=100,
responseTimeout=10,
readRetriesLimit=3,
autoReconnectPeriod=1,
localSourceAddr=“0.0.0”
] {
Thing device generic1 [
address=“1.1.1”,
fetch=true,
pingInterval=300,
readInterval=300
] {

    Type number        : Temp1       "Temperature" [ ga="9.001:<2/2/0" ]

}

Thing device generic2 [
address=“1.1.2”,
fetch=true,
pingInterval=60,
readInterval=60
] {

    Type number        : Temp2       "Temperature" [ ga="9.001:<2/2/0" ]

}
}

ITEMS file

Number Temp1 “Temp 1 [%.1f °C]” { channel=“knx:device:bridge:generic1:Temp1” }

Number Temp2 “Temp 2 [%.1f °C]” { channel=“knx:device:bridge:generic2:Temp2” }


So I thought I could have two different device things, one polled every 5 minutes and 1 polled every minute. It simply doesn’t work. I got strange result. Am I completely wrong?

Thanks in advance and regards
Alessandro

First point is, you must not set localIp to 0.0.0.0. Either leave the parameter uninitialized or set it to the IP of your openHAB server.
Second point: two things with an individual address should not be named generic but with a meaningful name, e.g. type of device (maybe tempSensor1…) If the individual address isn’t a real address, you must not set a fake address! For generic Things (i.e. no exact real device) don’t set an address at all, don’t set fetch at all, don’t set pingInterval at all, as this parameter won’t do anything.
Third point: leave pingInterval untouched, even if the individual address is the real one. This has nothing to do with readInterval.

Please consider to use code fences :slight_smile:

Bridge knx:ip:bridge [
    ipAddress="192.168.0.10", //ip of knx/IP gateway
    portNumber=3671,
    type="TUNNEL"
 ] {
     Thing device generic1 [
         readInterval=300
      ] {
         Type number : Temp1 "Temperature" [ ga="9.001:<2/2/0" ]
      }
     Thing device generic2 [
         readInterval=60
      ] {
         Type number : Temp2 "Temperature" [ ga="9.001:<2/2/0" ]
         //             makes no sense at all, same GA? ^^^^^ 
      }
 }

much more readable…

1 Like

Udo,
thanks for all your suggestions. I learned a lot and it worked great. Of course the same GAs was only a mistake writing the question.
Cheers
Alessandro

There might be a misunderstanding.

As far as I know (but I might be wrong), the fetch parameter is for fetching data from the KNX device itself, not for sending read requests to the GAs associated with the device.

What is your final goal, maybe there are other ways to archive it?