OH2 - freezes after some time

Today there was another freeze of writing Metrics to MySQL.
I’ve no also switched to the latest snapshot 2.3.0 Build #1188 and pray that it will work now…

my system is just getting better fixed the crashing. now jetty is acting up and reconnecting and disconnecting the sitemap every second.

I am gonna reinstall openhab this weekend.

I can confirm that with Version 2.3.0 my issues are gone.

I don’t use mysql but rdd4j. I hope the bug is gone for me with 2.3 also.

crashed again yesterday. Very dissapointed.

Oh man. I’m on the snapshot 2.3 since yesterday. Was hoping that the problem are gone. Will report back. Has anybody opened a issue already?

Hi, I have the same issues with MySQL persistence and openHAB 2.2.0-1 (Release Build).

After some weeks of uninstalling addons, I was finally able to get openhab stable by removing the MySQL persistence (currently I don’t use a persistence).

I didn’t have the issues with an older version of openHAB 2. But here I was running MySQL and openhab on the same raspberry pi.
In my current setup I have different raspberry pi’s for MySQL and openhab , could this be related?

Hi, I reinstalled my openhab install and the crashing is gone. The system is stable and running great.

I am running influxdb instead of MySQL. I think the issue was related to the sd-card getting older and slower. I now have a new sd-card. It hasn’t frozen since reinstall.

In my case I am running OH2 on a KVM virtual machine and don’t have a sdcard.
The crashes might be related to MySQL persistance storage.

I’m not using MySQL but the rdd4j persistence. I think it more related to persistence in general and not only with MySQL.

One interesting question from my side: Are you using Zulu Java 8 or something else ?

I’m using a standard openhabian installation and added piVCCU which is the gateway for my homematic devices. But before I installed everything from 0 again with openhabian, I was using raspian with a manual openhab installation. Both are crashing since 2.1. If I go back to 2.0
everything works without the freeze/crash.

Same for me, I’m using the standard openhabian image with some additional add-ons.

Same here, openhabian with Zulu Java 8. This is really disappointing as the whole thing doesn’t feel solid at all. Running in a ESXi VM.

I’m on one of the latest snapshots (2.3) now and had no freeze since two weeks. Using openhabian and rdd4j persistence.

I have the same problem since a month ago. I ended up adding a cron entry that reboots the system twice a day. A bad workaround, but it works for me.


With the latest snapshot and mysql persistence replaced with influxdb it works now for me without crashes since a couple of days.

Did you check the java heap space:

‘Karaf console: shell:info’

I had to increase the heap space, as my setup crashed every two days.


EXTRA_JAVA_OPTS="-XX:+HeapDumpOnOutOfMemoryError -Xmx512m"



Problem already solved? I also had the same issue - and thought, that the refresh-interval is seconds. it is not. it is millisconds. See:

I have the same issue, that openhab freezes after some days. Is there already a solution around? Rebooting every few days doesn’t look like a good one…