OH2 - freezes after some time

Tags: #<Tag:0x00007efec59419f0> #<Tag:0x00007efec5941928> #<Tag:0x00007efec59417e8>

Same here, but just using Homematic and HUE emulation binding on a raspberrz pi 2. OH2 service freezes. No more log entries are generated. This installation worked for years. The only change I did was updating to 2.1. Im totally lost now. Cant find any suspicious in the logs.

This still constantly happens and it’s really annoying. Since the whole house is dead when it happens.

Somebody any idea how nail down the root cause of this ?

After my first analysis this issue seems to be related with the graph features.
I’ve removed all graphs in my sitemap and now it’s not crashing anymore(knocking on wood).

I am using mysql as a persistence backend on a separate machine.

It sucks to give up graphing just to have the system stable.

have had the same problem with openhabian. The freezing started when I added charts to the sitemap for basic UI. Removed the chart, let’s see what it does.

i have similar issues.

zwave freezes after some time, something between 2h-24h

im always on latest snapshots, this issues starts before some weeks >4weeks.

using habpanel ui
jdbc-mariadb + mapdb persistence, i have also some charts in habpanel

i think it has something todo with the persistence engine.
couse it stops also persisting every2min

every2Min : "10 0/2 * * * ?"

I reverted back to an older version and the problem is gone. I’m curious if the problem was fixed with the newest version 2.2

Yes - I can confirm it is definitivly related to (MySQL)persistence and graphs.

And - NO - the problem was NOT fixed in Version 2.2 unfortunately.

Do you have the error msg form the log?

As far as I can see I don’t have any related error message when this happens.
Strange thing is that the system seems to continue running but all logics which need persisted items are f****ed up.

This a really a pitty. I have the feeling I have to leave Openhab2 because of this and go back to Smarthome.py

i am using mysql for data logging and charts, the msg i got is gone in the latest snapshot.

openHAB 2.3.0~20180115165618-1 (Build #1186)

Today there was another freeze of writing Metrics to MySQL.
I’ve no also switched to the latest snapshot 2.3.0 Build #1188 and pray that it will work now…

my system is just getting better fixed the crashing. now jetty is acting up and reconnecting and disconnecting the sitemap every second.

I am gonna reinstall openhab this weekend.

I can confirm that with Version 2.3.0 my issues are gone.

I don’t use mysql but rdd4j. I hope the bug is gone for me with 2.3 also.

crashed again yesterday. Very dissapointed.

Oh man. I’m on the snapshot 2.3 since yesterday. Was hoping that the problem are gone. Will report back. Has anybody opened a issue already?

Hi, I have the same issues with MySQL persistence and openHAB 2.2.0-1 (Release Build).

After some weeks of uninstalling addons, I was finally able to get openhab stable by removing the MySQL persistence (currently I don’t use a persistence).

I didn’t have the issues with an older version of openHAB 2. But here I was running MySQL and openhab on the same raspberry pi.
In my current setup I have different raspberry pi’s for MySQL and openhab , could this be related?

Hi, I reinstalled my openhab install and the crashing is gone. The system is stable and running great.

I am running influxdb instead of MySQL. I think the issue was related to the sd-card getting older and slower. I now have a new sd-card. It hasn’t frozen since reinstall.

In my case I am running OH2 on a KVM virtual machine and don’t have a sdcard.
The crashes might be related to MySQL persistance storage.

I’m not using MySQL but the rdd4j persistence. I think it more related to persistence in general and not only with MySQL.