OH2 - Homekit integration does not work anymore


I have OH2 with HomeKit integration running for a couple of month now. Last week I rebooted my router and I have lost the HomeKit integration ever since. I tried reinstalling, restoring from backup … It is not working anymore.

I deleted the Openhab bridge from the “Home”-App to (re)add it again. Unfortunately no iOS device can finde this bridge.

These are the instructions I followed, after I installed it for the first time:

I tried to uninstall and reinstall everything homekit related, but was not successful yet.

How can I find out why it is not working, and how do I get it to work again?

I really hope someone can help me.


Can someone help me. I really don’t know how to proceed anymore. I tried reinstalling on another SD-Card but was not successful. I hope someone has an idea on how to solve this.

I’m having exactly this issue too. HomeKit worked great for months and now is completely inoperable after I rebooted my router. Tried uninstall/install of HomeKit plugin. Tried removing openhab hub from Home app, but now is doesn’t appear at all to add it back.

I had the same issue. After checking I realized, that the IP address of my openhab system has been changed. And the Homekit service requires the IP address in the configuration (hard coded). After updating the IP address my system went back to working. Maybe that helps you.
Cheers, Felix

Unfortunately that isn’t my issue. I have the openhab system’s IP manually assigned in the router, so it hasn’t changed.

I am also using a static IP address.

Does anyone else have an idea? It is so frustrating, because it was working great, especially with the favorites in control center. Now, it is difficult for me to accept a situation without HomeKit integration.

I really hope, someone knows why I cannot add it again. I have also read, that HomeKit developer kit is open now, is that true? If so, I would think, that the HomeKit bindings would become more reliable and compatible.

I so hope someone can help.