OH2 Hue Binding - "White" vs. "Color" Mode Issues

Just got the Hue binding setup and I am seeing some strange behavior. I have the 2nd Gen A19 bulbs which have a set of white LEDs and a set of color LEDs. There seems to be syncing issue with the channels. Please see the screenshot below. The Dimmer is the “brightness” channel, Whites is the “color_temperature”, and Color is “color”.

1st Problem:
When I slide the dimmer, the light dims. In the color picker , when I adjust the B value of HSB, the light also dims, BUT the Dimmer slider only updates intermittently. The two are not always in sync.

2nd Problem:
If the lamp is displaying a color, when I slide the “color_temperature” (Whites), the light switches over to the white LEDs. Then if I got into the color picker, the S value of HSB sometime changes, sometimes not.

It’s a little confusing how to switch the bulb “White” to “Color” mode.

Been playing with the Hue API and I see it by design, you just have to understand what’s going on. Below is a result of a GET from the bulb. The OH “brightness” channel, and the Brightness setting in the OH “color” channel are one in the same, they change one value in the bulb, “bri”. I misspoke, both values update correctly in HB.

The bulb operates in two different mode as I suspected. You can see that below under “colormode” which is currently set to “hs”, the other mode is “ct”. The bulb sets this automatically depending on what you send it. The bottom line, is the color picker in HB will give you complete control of the bulb by allowing you to set Hue, Saturation, and Brightness (HSB). The “color_temperature” and “brightness” channels exist for convenience. The “brightness” channel just another way to change the B value in HSB. “color_temperature” is a little more complicated. It adjusts just the H and S, but limits the colors you will see to shades of whites (in the bulb, “colormode” changes to “ct” when you adjust this slider.

What confused me was the following: I would slide the “color_temperature” to get some white light. Then I would want some color, so I would open the color picker and choose a color from the outside ring…nothing would happen! Why? because it did not occur to me to adjust the Saturation, the middle left slider. When you are in the color picker, you are in full manual control. You must consider all three settings, HSB. Hope this helps somebody :slight_smile:

“state”: {
“on”: true,
“bri”: 137,
“hue”: 16800,
“sat”: 72,
“effect”: “none”,
“xy”: [
0.4144,
0.3977
],
“ct”: 299,
“alert”: “none”,
“colormode”: “hs”,
“reachable”: true
},
“type”: “Extended color light”,
“name”: “Hue color lamp 1”,
“modelid”: “LCT007”,
“manufacturername”: “Philips”,
“uniqueid”: “00:17:88:01:10:31:a9:26-0b”,
“swversion”: “5.38.1.14919”

Another note, if the bulb is in “ct” mode, (ie you touched the “color_temperature” slider), and then you turn the “effect” channel on, the bulb just cycles through shades of white. To get color, you need to touch something in the color picker first, which return the bulb to “hs” mode.

There actually is no brightness channel available for bulbs that have color - so you should use a slider widget for the color channel.

Regarding the ct issues: Feel free to enter bug reports at https://github.com/eclipse/smarthome/issues, this is where the binding is maintained.

Ok, thanks for the response Kai. In my last round of troubleshooting, I have been only sending an HSB type value to the color channel of a single Hue device. I very quickly lose communication to all Hue devices. Once I get a better idea of the exact sequence that causes the communication drop, I’ll submit the report.

My issues have nothing to do with the Hue Binding, please see https://community.openhab.org/t/intermittant-rule-issue/11663