OH2 loses communication with Wemo devices

I’ve been noticing that, on occasion, maybe once a week or so, OH2 cannot communicate with my Wemo devices. I have a Wemo link communicating with 3 Wemo dimmable bulbs, so it may very well be the communication with the link is lost. I can still use the iOS app to control the bulbs when this happens, but I cannot control them through OH2. Their state is not reported correctly and attempting to toggle their state fails. A restart of restart the OH2 service resolves the issue and everything works fine for a couple of weeks. Is this a known issue with OH2/Wemo link running on RPi3? If so, I can set a cron task on my RPi 3 to restart the service weekly. Just curious if there might be something else that might be the matter.

Just to give a more complete picture of my setup:
I use a python script via a cron task to toggle the lights morning and evening and it logs its activity to the console. The script is indeed launching, as the logs report, except when the problem occurs, the lights do not toggle as expected. Manually running the script fails as well.

1 Like

What does your python script do exactly to control your lights?
Why not use WeMo binding with openHAB rules to control your lights?

I did not face the issue you describe, no need to restart openHAB regarding to my WeMo devices.

So, even more detail. My RPi 3 uses a light sensor to detect the outside light level. The sensor is polled periodically for the current light level. When a threshold is reached, an MQTT message is sent to OH2 to toggle the lights.

“My Break-Dancing days are over, but there’s always the Funky Chicken” – The Full Monty

To understand you right, when the problem occurs, you are not able to control your lights via openHAB directly?

Could you please post your debug logs for this situation.

Correct, I cannot control the lights in OH when this happens. I’ll post the logs later this evening when I get home.

“My Break-Dancing days are over, but there’s always the Funky Chicken” – The Full Monty

Here is the output from the log at the time the lights should have toggled:

2017-08-09 21:03:38.828 [WARN ] [thome.binding.ntp.handler.NtpHandler] - ntp:ntp:local couldn't establish network connection [host '0.pool.ntp.org'] -> returning current sytem time instead.
2017-08-09 22:43:31.348 [ERROR] [ome.binding.wemo.handler.WemoHandler] - Failed to get actual state for device 'wemo:insight:Insight-1_0-231627K120006B': Could not call WeMo
2017-08-09 22:43:31.362 [ERROR] [ome.binding.wemo.handler.WemoHandler] - Failed to get actual state for device 'wemo:socket:Socket-1_0-221710K01048A3': Could not call WeMo
2017-08-09 22:43:36.901 [ERROR] [o.discovery.WemoLinkDiscoveryService] - Failed to get endDevices for bridge 'wemo:bridge:Bridge-1_0-231551B01006E7'
java.lang.RuntimeException: Could not call WeMo```

It looks like there is some issue in your network/setup, as three WeMo devices are not reachable at the same time.

The WeMo Binding is sending a SOAP request to receive the actual state of the devices, but never gets an answer. As a result, the ERROR is logged.
This can happen from time to time, but unusual for several devices at the same time.

To track this down, you could use a packet sniffer to see, what message is send to the device and if it sends back an acknoledge followed by an answer.

Looks like the issue may be elsewhere as i’m having trouble with incandescent bulbs as well.

Indeed, there were a couple of issues that led to this problem. An electrical problem had to be resolved and the Wemo link needed to be reset.

How do I mark an issue as solved?

You could change the title of your first post and add [Solved] at the beginning, or press the three dots underneath your last post and use the tick box.