OH2 -> OH3 older bindings no longer supported


I’m looking into upgrading my existing version 2 installation to version 3. Upon reviewing the bindings available i discovered that 2 of the bindings that i use are no longer available, LightwaveRF and MIOS.

The LightwaveRF binding controls all the lighting in the house via the Wifi Link. This could be substituted for RFX binding but then i would also loose the power usage that the binding also provides. Not to mention the additional cost of the RFX transceiver.

The MIOS binding controls all the heating devices (zwave radiator valves, room thermostats and boiler controls). The zwave devices could be repaired to a new controller but that would involve significant downtime whilst the migration was completed (i.e no heating).

So I ask if anyone has any suggestions as to how to proceed with this endeavour.

I have noticed in the binding for the zwave controller there is an option called “Controller is Master - For most systems, this should be set to true - the only time when it should be false is if you normally control your Z-Wave network through a different system.”. How does that work?

Any ideas/suggestions would be welcome.

Kind regards


Hi, I’m currently integrating lightwave for v2.5 and v3.
I’m currently testing so will need your assistance very soon :+1:
Search new lightwaverf binding for the current thread. Only gen2 supported and working at present but close on the gen1 side

I believe (maybe wrong) this now Vera binding

One other option is to keep an OH2 system running & use the remoteopenhab binding to pull the Items into OH3.

Hi Dave,

I’d be happy to do some testing when you get the gen 1 support completed.
All my units are gen 1, mainly light switches, also have the power meter, a 3 way relay and a couple of sockets.


For MiOS, a few of us have tried some things over in the thread below, and it looks like most are settling for using the new HTTP binding.

Can you link to this binding? Can’t see it in the docs…

I dont think its merged yet but looking below and clicking on the pull request (crossed through) it looked like it

ive sent you a prebuit jar to get some data from you. the more i get the quicker it gets done :+1:

Ah, yeah, that’s the one I discuss here. I’m pretty sure it’s dead, unfortunately.

if the code is there, set up an ide, look through it and piece it together. once you get the basics its not that difficult. i had a binding out there in 30 days, albeit not polished, but at least you can compile it, test to see if it works for your devices and modify. if it was ready to be merged but the author disappeared then theres a good chance it will work anyway. just need to grab the code from github, compile it and drop the jar in.

ill even grab the code tomorrow and see if it compiles for you to test

If you mean me - no need, I’m happy with the HTTP Binding. However, I’m sure there would be interest in a proper binding for Vera/MiOS devices, though if you don’t have one yourself then that might be quite tricky…!!

It’s not the trickiness it’s the time… 2 bindings is enough for me to develop/maintain :joy:

I’ll check it out tomorrow anyhow.

Hi all,
I recently installed openHAB3. It works fine, but I have problems to get my AeonLabs minimote working.
It is well recognized as thing, but the channels are not found. So I can not link any item to it.
Exactly the same phenomene occurs on the Aeon Wallswitch.
I defined an Number-item in the item-file to get the scene_number.
With openHAB2 it worked.
Any idea ?