OH2 on Synology with USB stick - ACM0 not found


I have been trying to get this working.

The setup is a Synology NAS box, clean install of DSM 6.01 with OpenHab2 2.0.0 and 2.1.0 (tried both).

The issue is that I can’t get the Aeotec ZWave usb stick 5 to be recognised. " Serial Error: Port /dev/ttyACM0 does not exist"

The port is correct, I can ssh into the box and it reports correctly. I installed domoticz and was able to access the stick through that with no issue at all, on ttyACM0 as well.

I have been digging through threads on permissions all day and haven’t been able to make any difference. Users, groups… nothing has changed the end result.

Any suggestions where I can go from here? Or am I left with just going back to domoticz…

It’s probably Java who can’t access the ports, because you need to add them to the startup arguments like this:

I had a similar problem, when running OH2 with in eclipse in Ubuntu 16.04.
I had to open the permissions on the serial port. See [SOLVED] Zwave controller fails to initialize when executed within eclipse


could you solve the problem?
I have the same problem…but no sulotion.

Been playing around With this problem for days now to get the Aeon stick to work on a Synology DS118.

I can see the port as ttyACM0, and see it dissapears when I unplug the stick.
Tried everything from the chmod 777 /dev/ttyACM0, added user to usergroups (dialout, uucp, tty), permissions on the Lock-folder, startupscripts because permissions gets resetted on reboot, and a lot more.
Nothing Works …

Then I tried it on a Synology DS218+, and Guess what - worked like a charm … on the first try …
The port even got showed in a “Select Box” in the paper UI - just point and click :slight_smile:

The only problem now is that the 218+ is not mine, so I kinda moved back to start.

Anyone got an idea of what could be the problem on the 118?

I’ve detailed how I’ve set it up on a DS214play in the post below. Hope it helps.

Thanks for answering Neil, but as I googled around I’ve allready seen and tested your approach. Re-tested it now with a reinstalled synology os, and still not working. I’ve also installed the Domoticz to test the ttyACM0-port on the DS118, and no problem there - the stick works perfectly. What still bugs me, is that the problem doesn’t occur on the DS218+, and now of course in Domoticz.

The DS118 has a Realtek RTD1296 processor whereas the DS218+ an Intel Celeron J3355. So perhaps some native libraries shipped with openHAB don’t support that architecture?

I have a DS218+ and the /dev/xxxx doenst show up in mine.