OH2 will not start

When i start OH2 under Windows 7, nothing happends.

Here is what i did:

  • Downloaded offline-2.0.0-snapshot
  • Installed jdk-8u111-windows-i586
  • fixed empty JAVA_HOME variable by setting env. variable to: C:\Program Files\Java\jdk1.8.0_111 and including C:\Program Files\Java\jdk1.8.0_111\bin in PATH.

Java version is:
java version "1.8.0_111"
Java™ SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot™ Client VM (build 25.111-b14, mixed mode, sharing)

If i start OH2 in debug mode, i get:
Launching the openHAB runtime…
Listening for transport dt_socket at address: 5005

And then nothing else… Any ideas?

First start takes a couple of minutes … did you wait long enough?

A few hours :slight_smile: Still no change.

That’s long enough … no ideas, sorry, never have used openHAB with Windows …

…i am running 1.8.3 on the same server, and that has been working all along.

My stupid idea: you did shutdown 1.8 before starting 2.x?
Both versions at the same time on the same server won’t work …

Offcourse :slight_smile:

I remember from a test installation about two years ago that openHAB did not work while installed in C:/Program Files.
I had to put it in D:/openhab or something (maybe it was “Documents”), then it worked.

And maybe this thread could be of help:

Changing from the offline to the online version made it work. I never found the reason, but im up running now :slight_smile: