OH3.1 - Need Help Configuring a ZWave LS100+ Leak Sensor

I need help getting a Homeseer HS-LS100+ working. I used Main UI to include the sensor into the zwave network, added the thing and added items for the flood-alarm and battery level channels. Everything seems normal and MainUi shows the thing as Online, but the items are never updated - after three days they are still null.

I’ve tried excluding/including the items multiple times including deleting the nodes from the controller (Aeotec Z-Stick gen5), but the result is always the same – the items are never updated.

The one oddity that I found is that there is no file for the node in the userdata/zwave folder. I added a couple of dimmers a week ago and the files exist for those nodes.

The thing’s configuration is:

UID: zwave:device:39d51d11b2:node32
label: Master Bath Left Leak Sensor
thingTypeUID: zwave:homeseer_hsls100_00_000
  config_20_2: 1040
  config_32_1: 20
  wakeup_interval: 0
    - controller
    - controller
  wakeup_node: 1
  config_17_1: 5
  config_18_1: 0
  config_19_1: 0
  config_22_2: 320
  config_24_1: 1
  config_14_1: 1
  node_id: 32
  config_15_1: 0
bridgeUID: zwave:serial_zstick:39d51d11b2

The channels are:


And the items are:

Can anyone help with this? I’ve exhausted everything I can think of to try to get these working.

Openhab 3.1.0 Relase Build running in Docker on a Synology NAS.

That means it has not been fully discovered by the binding.A common problem with battery operated devices.

Thanks for your help.

What can I do to resolve this?

look at the documentation for the device and figure out how to wake the device. Start the inclusion process in openHAB and then wake the device, repeat if needed, it often takes many tries

What I would do is delete the Thing from OH, rediscover & then wake up repeatedly. if you have DEBUG logging turned on you can usually see the device state., Trying to heal it will throw an error if ir is not fully discovered.

I was finally able to get the devices included into OpenHab. My solution:

  1. Deleted the Things/Items that were not working properly from OH3
  2. Shut down OH3.
  3. Used the Zensys tool to remove all ghost nodes from the controller.
  4. Restarted OH3
  5. Used MainUI to disable all of the zwave items except the controller.
  6. Used MainUI to put the controller into Include mode.
  7. Pressed the button on one of the devices to put it into Include mode. The LED would turn on, flash blue for awhile, and then turn solid blue after about five or six minutes. As soon as the blue light went out I tapped the device’s button four times quickly to wake up the device (the LED flashes yellow quickly in wake-up mode). Repeated waking the device up for an additional five minutes each time the LED turned off.
  8. Repeated steps six and seven for each device that I wanted to include.
  9. After including all five devices when back to MainUI and enabled all of the zwave devices previously disabled.

I suspect some of these steps were not necessary, but this worked for me.

Thanks four your help.

I can confirm that the process above worked for me too. A key for me was that if, during inclusion, it does not blink blue for several seconds, and then go solid blue for several minutes, something is wrong.

One thing I did a little different was I added the Thing after it was identified in the mailbox, and then immediately added Items to the thing while the light was still blue. The master alarm, temperature and battery items usually populated after the first wake-up (4 taps quickly, flashing yellow).

When I added my 8th device, I simply did the following process:

1.) Put controller into inclusion mode

2.) Tapped the device button once.

[Device Light blinks blue for a period of time (30 seconds?), and then solid blue (minutes)]

3.) Device shows up as a new scanned device in the inbox as:
Z-Wave Node xxx: HS-LS100+ HomeSeer Z-Wave Plus Leak Sensor

4.) Add the device as a Thing.

5.) Immediate go and create Items and link one Item to one Channel.

6.) When the solid blue light goes out, press the button four times quickly to wake up the device. Shortly (5 secs) thereafter the Items should populate with a value (Binary Sensor, Sensor (temperature) and Battery Level.

7.) When yellow light stops blinking put the wired probe assembly into some water. The binary sensor channel (zwave:device:xxxxxxxxxx:nodeyy:sensor_binary) should go to ON/Triggered, and the Flood Alarm channel (zwave:device:xxxxxxxxxx:nodeyy:alarm_flood should go to ON/Alarm.

The fire and tamper alarm are still NULL for me.

For my last device (8th) I did not disable all of the zwave things except the controller, doing that step was such a pain for me, I didn’t want to do it again. I have about 30 zwave devices on my network.

Lastly, I did have some “ghost nodes” before I was successful adding in these devices. I did go and clean those out with PC Controller 5.

I also restarted and rebooted the OpenHAB host several times, cleared cache, and other steps, but I don’t think (based on successfully including the 8th item 24 hours later) those helped.

I hope this is helpful for the next person with these devices!


1 Like