[OH3.1M3] [shelly] CoIoT Unicast behind reverse proxy


I loved to see, that Milestone 3 comes with the new Shelly Manager. A great tool.
I also updated all my shellys to firmware 1.10 so I can use CoIoT Unicast, because multicast doesn’t work with openHAB in docker behind reverse proxy.

As already mentioned I run openHAB in a docker container behind a reverse proxy.
In the shelly binding I configured the ip address of the host interface to the ip from the docker host (not the container)
In the device configs I configured the CoIoT peer to <ip_of_docker_host>:5683

And now I got the following errors in shelly manager or log:
2.) Count of CoIoT Messages: 0
3.) Message in openHAB.log:
CoIoT peer in device settings does not point this to this host, disabling CoIoT

Device-Updates from shelly only receive with delay to openHAB.
What am I doing wrong?


Did you already found a solution for this? I have the same situation.


the problem is discussed in the thread about the shelly binding:

But I have to admit, that I didn’t do any tests.
I don’t know, if the changes already moved to production.


My issue was a bit different, I guess.

If I use docker containers in bridge mode with port forwarding the unicast or multicast didn’t reached OH3.
Using network=host it’s working after I has set the IP initially to one of the Shelly devices. I guess the OH3 instance wasn’t anymore member of the “mcast” group. After changing one of the Shelly’s it was working with all devices, too. But only if host network is used.