OH3 Alexa Endpoint Metadata

Hi there

I’d like to understand how to add Alexa Endpoint metadata to item group from UI.

Is the Endpoint metadata mandatory for Alexa?
From Alexa point of view grouped items should be discovered as single device?

In order to give you a proper response, could you provide some more information such as your item definition you are trying to model for Alexa?

Only group items with derived state from member items are discovered as single endpoint devices.

Thank for your help.

Actually I’d like to expose a custom thermostat to Alexa.

I have group item with 4 sub-items:

  • “Caldaia” is the boiler state heating/non heating
  • “Temperatura attuale” is the actual room temperature
  • “Temperatura” is the temperature set point
  • “Riscaldamento” is the state on/off

I managed to set the capability(ThermostatController.targetSetpoint and so on) to every single item but they are discovered individually by Alexa and I suppose I was missing the “Endpoint.Thermostat” on group metadata but did’t find a way to add.

You just need to configure the Alexa metadata on your thermostat group item. You should have an option in the metadata section to do so. Make sure to delete your existing Alexa discovered items after making the change.


Hey Jeremy
You very kindly helped me to get the #Velbus thermostat presets up and running with OH2 and your Alexa V3 binding

This worked perfectly.

Now that we are moving to OH3, it seems that Alexa can’t set the PreSet any more.

For example, I ask Alexa

Alexa, set the back bedroom preset to night

and it replies with

  • I don’t know how to set xxxx to that setting
  • That’s not supported yet

or I once heard it say

  • I can’t do that yet

Is there any chance you can explain what’s happened, or even better, can you shine any light on what I need to change to when it might be supported again?


It does support these utterances

Alexa, what’s the temperature in the back bedroom?
Alexa, set the back bedroom to 20 degrees
Alexa, what’s the back bedroom set to?
Alexa, set the back bedroom to heat
Alexa, set the back bedroom to cool

Thanks in advance for you help and support.

There are no changes in how the skill interacts between OH2 and OH3. So if you kept the same exact configuration, there shouldn’t be any differences.

One thing to note is that supported modes text labels are language-based. If there is a language mismatch between your OH server and your Echo device, the label names wouldn’t be recognized. I would recommend checking your regional server settings.

1 Like


I’m fairly sure I haven’t changed anything, but I will double check.

(I’m in England, so would have thought the default EN language was good, it’s not something I’ve changed before. The only thing that has changed is that I’m now running OH3)

That’s what I would assume but I just wanted to make sure that you didn’t somehow configure incorrect regional settings.

Other than that, I would recommend signing up for the beta test. It is backward compatible with the current metadata syntax and would make easier to troubleshoot your issue along with applying any necessary fixes going forward.

1 Like

Thanks Jeremy

I’ll complete that form today.

Do I need to do anything, or will you give me a shout when you need more information?

(I’m happy to test anything you need me to, or send you copies of Items files etc)



I am trying to setup the Alexa Thermostat into MainUI.

I created a group, equipment and added my items (mode, fan speed, power switch, setpoint) and set the meta data as ‘Endpoint.Thermostat’

I can discover the device fine, how issuing mode commands etc dont work ‘Garage Air’ doesnt support that.

Here is the group

And I put the supported modes, under the Mode Item meta data

Is this the correct method? It’s not described in documentation I can find.


You don’t need to set the supportedModes parameter. It is derived from the specific mode mappings you configured. In your case, it will be set to supportedModes=OFF,HEAT,COOL,AUTO. As a side note, Dry mode isn’t supported by that interface.

1 Like

OK, and I assume the [] aren’t required when entering this into MainUI?

So its entered like so?