OH3: amazonechocontrol won't let me login

If I try to login via the amazon sign-in from my OH3-installation, I get an SMS from amazon.com to allow the access (2-step verfication is ON).
So, what happens?

  1. activated amazonechocontrol binding on OH3
  2. added “amazon account” as Bridge
  3. opened http(s)://<YOUROPENHAB>:<YOURPORT>/amazonechocontrol/<IDENTIFIER>
  4. logged into my amazon-account
  5. get SMS and clicked as fast as I could on the activation link
  6. get logged out of my account and get redirected to login-prompt (see step 2.)

…and I can do it over and over again. Tried three times, with increasingly faster response at step 4, but without any help. I don’t want to deactivate 2-step verification for this… Is there anything I can do?

Die you follows These steps to enable 2 Step verification?

yes, 2-step verification is alive and kicking! :wink:

just changed from SMS to Authenticator OTP, and now it works…
seems, SMS-Authentication is not supported either from the bindings perspective or it messes something up within amazons rules…