OH3 and Fronius-Binding

@chilobo are you still experiencing this issue?

Unfortunately the binding didnt update. I’ll need to find out why … will do that as soon as possible.

Yes, and there does not seem to be any pattern to it:
Fronius_eventlog_220207.txt (12.4 KB)
But I am not using your posted binding but the one supplied with openhab 3.3:

238 â Active â 80 â 3.3.0.M1 â openHAB Add-ons :: Bundles :: Fronius Binding

Other devices (Powerwall, Shelly) attached to this router do not show these problems, so it seems to be a problem of the Fronius Symo.

After copying a jar to the addons directory I stop and start openhab in the console:

 sudo systemctl stop openhab.service
 sudo systemctl start openhab.service
1 Like

Hi,
the list command shows both versions as active now. Do I have to uninstall the old binding first ?

openhab> bundle:list -s | grep froni
243 x Active x  80 x 3.2.0                 x org.openhab.binding.fronius
263 x Active x  80 x 3.3.0.202202081345    x org.openhab.binding.fronius
 openhab>

Yes you could try uninstalling the binding from the ui if that’s where youu installed it originally.

If you installed it via addons.cfg remove fronius from the list, if you have other binding on the list.

If it is the only binding, do not just comment out the line. You need to just delete the word fronius from the file.

And try restarting openhab after uninstalling if necessary.

@chilobo the version I posted above for Franz doesn’t fix the timeout errors. I have a different version that does, but I’m still testing it. I can see the timeout errors on my system too, hence the fix. Hopefully I’ll be able to post it here very soon.

1 Like

@chilobo please test this jar to address the communication errors:

It should have the following version:

openhab>
bundle:list -s | grep froni
237 │ Active │  80 │ 3.3.0.202202090013    │ org.openhab.binding.fronius

Please let me know how it goes. Thanks.

First I thought that nothing changed, but I had not deactivated the original binding. At 13:15 I deactivated it:

openhab> bundle:list -s | grep froni
238 │ Resolved │  80 │ 3.3.0.M1              │ org.openhab.binding.fronius
253 │ Active   │  80 │ 3.3.0.202202090013    │ org.openhab.binding.fronius

Since 13:15 the connection to the Fronius thing ist stable. :slight_smile:
Thank you!

1 Like

@chilobo, Thanks for testing and providing feedback.

I have a newer version that better deals with failures when it’s connected to an unknown host (e.g. when you’re pointing it to another unrelated HTTP server)

I have submitted this as a PR:

Good morning,
I uninstalled the binding from GUI, restarted, and now it works !
The only issue I noticed is that I do still get zero values for AC Currents. All other values are reported now.
Thanks a lot
Brandy

Hm … 10 min after starting openhab I get:



2022-02-10 09:59:38.747 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'fronius:powerinverter:FroniusBR:FroniusIN' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Transfer timeout.

2022-02-10 10:00:39.309 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'fronius:powerinverter:FroniusBR:FroniusIN' changed from OFFLINE (COMMUNICATION_ERROR): Transfer timeout. to ONLINE

using:


253 │ Active   │  80 │ 3.3.0.202202100157    │ org.openhab.binding.fronius

and some time later:

2022-02-10 10:08:45.207 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'fronius:powerinverter:FroniusBR:FroniusIN' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Transfer timeout.

2022-02-10 10:09:45.542 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'FroniusSymoInverter_ACPower' changed from 74.0 to 71.0

2022-02-10 10:09:45.550 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'fronius:powerinverter:FroniusBR:FroniusIN' changed from OFFLINE (COMMUNICATION_ERROR): Transfer timeout. to ONLINE

But “transfer timeout” is different from the previous error messages.

AC Power shows correct values.
@Franz Brandl: Do the daily reports or the Fronius app show correct values? If not, it could be a hardware problem of the Smartmeter.

EDIT: Updated to v0.0.4

Thanks for testing, @chilobo. I have found the cause of this error, and hopefully fixed it too. Please try v0.0.4 below

Yes, I am aware of this. I have uploaded a new version that should have the AC currents here:

1 Like

Currents are there, thank you !

1 Like

Thanks for the confirmation. Link to PR:

1 Like

I’m also trying to use the Fronius Binding. For some reasons I do’nt see all the Channels.
When I’m trying the Link you postet earlier I get this results:

   "Body" : {
      "Data" : {
         "Current_AC_Phase_1" : 1.976,
         "Current_AC_Phase_2" : 3.0899999999999999,
         "Current_AC_Phase_3" : -1.365,
         "Current_AC_Sum" : 3.7009999999999996,
         "Details" : {
            "Manufacturer" : "Fronius",
            "Model" : "Smart Meter TS 65A-3",
            "Serial" : "2411659742"
         },
         "Enable" : 1,
         "EnergyReactive_VArAC_Sum_Consumed" : 30180.0,
         "EnergyReactive_VArAC_Sum_Produced" : 5982614.0,
         "EnergyReal_WAC_Minus_Absolute" : 1499147.0,
         "EnergyReal_WAC_Plus_Absolute" : 5376551.0,
         "EnergyReal_WAC_Sum_Consumed" : 5376551.0,
         "EnergyReal_WAC_Sum_Produced" : 1499147.0,
         "Frequency_Phase_Average" : 49.899999999999999,
         "Meter_Location_Current" : 0.0,
         "PowerApparent_S_Phase_1" : 410.89999999999998,
         "PowerApparent_S_Phase_2" : 657.5,
         "PowerApparent_S_Phase_3" : 303.80000000000001,
         "PowerApparent_S_Sum" : 1372.4000000000001,
         "PowerFactor_Phase_1" : 0.63200000000000001,
         "PowerFactor_Phase_2" : 0.96299999999999997,
         "PowerFactor_Phase_3" : -0.72599999999999998,
         "PowerFactor_Sum" : 0.68999999999999995,
         "PowerReactive_Q_Phase_1" : -318.39999999999998,
         "PowerReactive_Q_Phase_2" : -177.59999999999999,
         "PowerReactive_Q_Phase_3" : -209.0,
         "PowerReactive_Q_Sum" : -705.0,
         "PowerReal_P_Phase_1" : 259.69999999999999,
         "PowerReal_P_Phase_2" : 633.10000000000002,
         "PowerReal_P_Phase_3" : -220.5,
         "PowerReal_P_Sum" : 672.29999999999995,
         "TimeStamp" : 1651910417.0,
         "Visible" : 1.0,
         "Voltage_AC_PhaseToPhase_12" : 399.39999999999998,
         "Voltage_AC_PhaseToPhase_23" : 395.69999999999999,
         "Voltage_AC_PhaseToPhase_31" : 400.89999999999998,
         "Voltage_AC_Phase_1" : 231.30000000000001,
         "Voltage_AC_Phase_2" : 229.90000000000001,
         "Voltage_AC_Phase_3" : 229.40000000000001
      }
   },
   "Head" : {
      "RequestArguments" : {
         "DeviceId" : "0",
         "Scope" : "Device"
      },
      "Status" : {
         "Code" : 0,
         "Reason" : "",
         "UserMessage" : ""
      },
      "Timestamp" : "2022-05-07T08:00:17+00:00"
   }
}

How do I get the missing Channels?

All the channels available from the binding are listed on the docs. The binding doesn’t provide all the json data

Thank you for your replay, but what docs are you talking about?

My apologies, I misunderstood your question. Which channel specifically are you missing?
Which openHAB version are you on, and which bundle version are you using (i.e. are you using a custom / updated bundle, or the one that shipped with openhab)? Some of the newer channels were added onto openhab 3.3 and not available with the bundle that came with openhab 3.2.

I use the the standard bundle, shipped with openHAB. It’s the Fronius Binding openHAB,

Source: openHAB Distribution
Version. 3.3.0.M3

Sorry, my bad. I found the Channels. Just need to calculate them for a better view.