OH3 API Access without Auth


Upgraded to OH3 and enjoying it, still some learning curve.
Some of my other systems has issue connecting to the API, due to authentication required.
Blue Iris, Node-red won’t work for me, tried enabling basic auth and using user:pass@ip but its not working.

Can I disable auth for API completely ?

Newest versions permit Basic Auth if enabled. I am starting to test that now with HABapp.

Or you can create an authorisation token as explained by Yannick here HABApp - Easy automation with openHAB

Works fine in HABApp in my local testing (Milestone 2)

1 Like

I have M2, and enable basic auth. however when I try to use it in Blue Iris for example, it wont work part of the URL (http://user:pass@/rest

I did create token, how can I use it part of the URL/URI ?

I’m just using it instead of the username & password combo - the username is the token string in my HABApp config and no password is then needed.

1 Like

Cool, Tried now http://token@ in blue iris alerts and its working !

It worked for Blue Iris. but for Node-red its not exactly working.
Seems like it can read the data once, but won’t get updates or something

and in the logs from node-red
9 Nov 19:56:52 - [warn] [openhab2-controller:Openhab] ERROR {“type”:“error”,“status”:401}

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.