OH3 Bindings fail to downoad

I tried to install the ZigBee binding this morning but got this error

Blockquote2021-04-28 08:35:22.446 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-zigbee’: Error:
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.telegesis/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.xbee/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.ember/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.console.ember/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.console.telegesis/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.console/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.serial/3.0.1
Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zigbee.cc2531/3.0.1
In the old days we could download a .jar and drop it into the add-ons folder but I couldn’t finf the ZigBee jar.
Another post suggested retrying and that didn’t work. Yet another post suggested clearing the cache. This I stupidly did and now NONE of my bindings will load so I have a non-functioning OH3. The ‘Access rmote repository’ is set.
Any ideas what I can do to resolve this?

You could download the 3.0.1 openhab-addons.kar file, put it into addons folder and install your bindings from there…

Thank you. I think that will solve my loss of the 12 main bindings but I believe that ZigBee isn’t in the main repository. Have you any ideas shat it blocking the downloads?

Not sure why you think that, but the important issue would be if it is in the addons kar. Try it and see.

1 Like

Because this page

GitHub - openhab/openhab-addons: Add-ons for openHAB


You are refering to the addons repo, but the kar file does include “external” binding repos as well, so Z-Wave and Zigbee binding are part of this file.

I solved it by upgrading to OH3.0.2 as nothing else worked.