OH3 - Developer Sidebar missing

Hey :slight_smile:

I just created a new OH3 (docker) container (version 3.0.0 Release Build) alongside my already running OH2 container and I was wondering how I can enable the developer sidebar.

I am logged in as the admin user and under ā€˜Developer Settingsā€™ -> ā€˜Maintenance Toolsā€™ there is no option ā€˜Developer Sidebarā€™ as I saw it in the release candidates before.

Am I missing something that needs to be done in order to activate this feature?

Hello Chris_si,

Does not your browser have enough size of the window?
I checked the behavior, it occurs when I change the browser size too small.
If the browser has enough space, the developer sidebar setting should appear.

I did some further digging on that issue and it turns out that it has something to do with http and https.
I am running OH behind traefik to be able to access OH via https (self-signed certificate) and via domain. Traefik points to the OH http port 8080.

When I access OH via http and sign in with the admin account, all settings like the developer sidebar are shown in the settings menu.

But when I access OH via https and sign in, some settings are missing. The things I found so far are the developer sidebar and the ā€˜pencilā€™ button on the homepage saying ā€˜edit homepageā€™. Also the frontend language is different. (http: german, https: english)

My conclusion would be that some things donā€™t get set correctly in the frontend application when I access it via https but unfortunately I have no clue what could cause this issue.

I would suggest to refresh the cache again. This can be needed behind a reverse proxy because this performs heavy caching for performance. Open you OH webpage (with https via Traefik) and go to the help page. Scroll down and unse the button ā€œPurge chache and reloadā€ if this is available. (The button is only available if the app recognizes a caching behavior.)

Clearing the cache solves the issue. Now all settings are displayed as they should. Thanks for the hint! :slight_smile:

The width of the window was the problem in my caseā€¦ Thanks for this note @ab3be6.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.