OH3 does not respect the local timezone

Bingo!

  • WEBUI => Settings => Regional Settings. These were already set to Australia/Perth but that did not affect the log file timestamps.
  • But !!! adding the following to /etc/default/openhab (and restarting openhab) DID fix the timestamps.

EXTRA_JAVA_OPTS="-Duser.timezone=Australia/Perth"

Thank you.

Bit of a pity that with the TZ correctly set in the linux system, and OH3 Admin Settings … it is still is not respected in the logs.

I will see tomorrow if setting EXTRA_JAVA_OPTS="-Duser.timezone=Australia/Perth" fixes my Rules cron triggers.