OH3 - Edit Locations via "configure card" or "Edit YAML" is not working in OH 3 UI

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.4 8 GB, external SSD
    • OS: Pi Os Buster latest version
    • Java Runtime Environment: openjdk version “” 2020-11-04
    • openHAB version: 3.0.2 - Release Build

I am not able to edit the locations, devices and properties on my home overview tab.
When I click on the symbol next to a location or one of the others, the menu shows up but when I choose “configure card” or “Edit YAML” nothing happens.

The locations where created by the modell and the devices and properties by item definition.
All was created with the UI, no text files.

Maybe someone can tell me what to try.
Thx, Martin

Did you check if openHAB reports anything in the log? From my below linked post:

I had “similar” issues beforehand but quite likely different root cause.

Hi Chris,

thx for the advice, I tried but there was nothing in the log at all, when I try to edit the locations.
I can see all other events and lots of information, but nothing for my problem.
I tried to examine it in the developer console but even there I can see no javascript error or network calls.

What I saw: When I click on “configure card” in another layout page, e.g. at an item, then there is network traffic. The rest api sends all items back to the client.

If I do the same in the overview page with a location, then there is no network traffic at all.
Seems as if there is no XHR call at all to get any data from the rest api.

Is there a chance to take a look at the source code for the overview page to examine if there is a bug?

Indicates a more serious problem than editing, more like filestore is broken.

Seems so, I will wait for the next release and see, if it will work then.
It’s not really so important for me to solve this, it’s just that I wanted to add some pictures to the locations.
Everything else is working fine.

I can’t imagine a software release will fix something like a broken SD card. I don’t think this is going to just go away.

Or maybe it’s not quite “nothing at all”, or maybe looking in the wrong place? Was this an upgrade from OH2, have logs ever worked since then?

The logs are working fine, I could solve all my problems I had with stack traces I found in the log.
Right now everything is smooth and I just get errors or warnings when I work on custom widgets and do something wrong.

It was an update from OH2, but after I had some problems with that, I uninstalled OH3 and installed an Openhabian version of OH 3. Since then no problems.

I don’t use a SD-Card, I use an external SSD drive and zram to reduce disk access.