OH3: Floorplan

Hey Guys,

i just started to migrate from my OH2.5 to OH3.1…

i tried to find out how to use the floorplan (is new to me) how do i get a backgroud image uploaded ?
Wich types of images are allowed ?
in case of svg could svg tags (text) modified by a widgt ?

thanks in advance


Hi @lblabr,
explaining everything about floorplans would be a little bit too much here.
You could start here and search the forum for more information about it:

In short what I‘ve done:
-Upload a picture via samba share to html/floorplans folder in png or jpg format.
-Load the picture in floorplan page with path like „http://openhabIP:8080/static/floorplans/your_picture.jpg“
-Add marker in run mode, move it to a desired position and configure it.

Hey Dirk,

thank you very much for replaying. The Manual
i already found., but it’s not telling howto upload the picture. Due the fact that i’m using the docker container, i would like to stay with the configuration and the services from that. The /openhab/conf folder is mounted to host. but i don’t have a floorplan folder in there.

root@openhab-3:/openhab# ls
addons conf dist LICENSE.TXT runtime start_debug.sh start.sh userdata
root@openhab-3:/openhab# find . | grep static
root@openhab-3:/openhab# find . | grep html

In case of an other location then the openhab server, does the pictore gets loaded from extern ? it does not get copied from url given to the floorplan widget ?

svg is not supported ? could a static webpage be the background (with svg inside)

Thanks in advance


Create a folder

Convert the SVG to jpg

Hi Lars,

you don´t need to create a new folder.
Use the existing folder /openhab/conf/html and put in the picture there, b. e. wohnung.jpg.
In the configuration page from the floorplan, put in the url http://openhabIP:8080/static/wohnung.jpg

I tried with my docker installation and it doesn’t work. My http server listen to 8888, I tried using 8080 but there’s no answer. With 8888, I only get file not found. Files are in conf/html and also conf/html/floorplans.

ok forget it, I don’t know how but I misstyped my port in my openhab configuration, was listening on port 9999. It seems there’s something else listening on 8888 that I’ll have to check