OH3 + KM200 binding

Hi!

I have a Raspberry Pi 3 +. I installed Openhabian 1.6.2b and km200 binding on it. In the things menu, km200 bridge automatically appears with the correct IP address. I indicated private key and km200 bridge went online.
However, unlike OH2, no km200 supported things of type were found: heatSource, gateway, etc.
How to connect km200 correctly?

Welcome to the community, Andrey!

For me the km200 with OH3 is working.
Maybe you could disable the thing and then post the log when enabling it again - this would show the startup behaviour and would enable us to have a clue. Without it is just not enough information to come to a solution.

Hi,

since nothing happened in this thread I hope it is OK that I’m hijacking it with exactly the same issue.
I’m currently migrating from OH2 to OH3 and did a completely fresh install. I originally started with OH1 and things got messy over the years :slight_smile:

However, I wanted to setup my heating and installed the KM200 binding for OH3. When enabling the item, it comes online within a few minutes, but no channels are discovered.
Also in log nothing happens:

– switching KM200 item disabled and enabled again–
2021-01-28 14:52:04.917 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler KM200GatewayHandler tried updating the thing status although the handler was already disposed.
2021-01-28 14:52:04.923 [INFO ] [internal.handler.KM200GatewayHandler] - Update KM50/100/200 gateway configuration, it takes a minute…
2021-01-28 14:52:09.923 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing ‘km200:kmdevice:753419744’ takes more than 5000ms.
– 10 minutes nothing happens after this

IN OH2 everything worked fine. What I noticed that the item properties (dropdown when editing the item… dispay manufacturer etc) are discovered correctly.

Anny hints?

Thanks in Advance!

Just a wild guess: Have you configured the Java encryption security police to unlimited?

Hi and thanks…
I’m using openjdk 11… so it is enabled by default… I just double checked and the max AES keylen is 2147483647… so unlimited

I got it to work (basically with many retries, sometimes it discoveres things, sometimes not) but somehow problems still persist.
The the things of the KM200 often “loose” their channels… so when I look into the thing, the channels are gone. If i reconnect the bridge thing, then the channels are back again, however in the model the links between items and things break when this happens.
This is reeally annoying… in OH2 everything really worked well with the bidning

Any update on this topic? I tried several times but I never get any channels. According to the logs, everything is working properly - the endpoints are read. This takes a few minutes.
In the end, no channels show up and there’s no error in the log.

Just a rough guess: Could it be JDK-related?
I’m running Zulu11 and have no issues.
What platform are you running on?
Due to a hardware issue I had to setup OH from scratch and can confirm that it worked out of the box again.
Maybe setting the binding to DEBUG would provide more information in the log.

Platform is openhabian on a Raspi 4. Binding is set to TRACE and there’s a lot of:

2021-03-02 21:14:31.914 [DEBUG] [M200GatewayHandler$SendKM200Runnable] - Send-Executor started
2021-03-02 21:14:32.054 [DEBUG] [KM200GatewayHandler$GetKM200Runnable] - GetKM200Runnable
2021-03-02 21:15:02.055 [DEBUG] [KM200GatewayHandler$GetKM200Runnable] - GetKM200Runnable

But there’s also some messages about mDNS discovery

2021-03-02 21:15:57.890 [DEBUG] [ery.KM200GatewayDiscoveryParticipant] - MDNS info: [ServiceInfoImpl@8148182 name: 'Bosch SHC [<MAC>]._http._tcp.local.' address: '<IPv4 & IPv6>' status: 'NO DNS state: probing 1 task: null' is persistent, has data, empty], uid: null
2021-03-02 21:15:57.891 [DEBUG] [ery.KM200GatewayDiscoveryParticipant] - MDNS info: [ServiceInfoImpl@9898550 name: 'Bosch SHC [<MAC>]._http._tcp.local.' address: '<IPv4 & IPv6>' status: 'NO DNS state: probing 1 task: null' is persistent, has data, empty], uid: null
2021-03-02 21:15:57.892 [DEBUG] [ery.KM200GatewayDiscoveryParticipant] - hardwareID: null
2021-03-02 21:15:57.896 [DEBUG] [ery.KM200GatewayDiscoveryParticipant] - hardwareID: null

This is, however, my Bosch Smart Home Controller, not the Buderus.

I have similar messages for my Epson printer, guess that’s not the reason.
The other messages above are nothing special, just shows the binding is doing some work.
What I’m missing is the paths to the various values being logged.
Maybe a stupid question, but just to be sure:
The gateway thing itself has no channels that can be seen. What you are missing is not a channel, but the the things for e.g.warm water (which then should have channels) in the inbox. Correct?

Interesting question. I went with the Tutorial and, hence, with the UI setup for now. So I was expecting the channels to show up in the KM200/100/50 Thing -> Channels tab as is the case for my smart meter.

There are no other things registered in the UI. I’ve see the binding check the values of the corresponding endpoints in the log, e.g.:

2021-03-02 22:13:19.901 [TRACE] [internal.handler.KM200ServiceHandler] - initDevice: type float value: {"id":"/dhwCircuits/dhw1/actualTemp","type":"floatValue","writeable":0,"recordable":0,"value":50.0,"unitOfMeasure":"C","state":[{"open":-3276.8},{"short":3276.7}]}

So there are no things related to the km200 binding in the inbox?
Maybe a scan would help.
Go to Inbox, “+”, km200 Binding, “Scan”
Then accept the things discovered. Those should have the channels you are looking for.

1 Like

Thank you very much! That is where all the things were hiding… Still need to learn how the modelling is reflected in the UI. The Inbox didn’t show as I removed all but the smart meter and KM200 bindings to rule out other problems. Before, I had seen it from the hue binding. :slight_smile:

You’re welcome.
Nevertheless the problem did not relate to the one that was the reason for this thread and which is still waiting to be solved.