OH3 MainUi: crashed and stuck

I was creating a widget, then something went wrong and main ui stopped working. I restarted the whole system and after that i cant do anything.
I can only open Documentation and Tutorial links. Sidebar buttons dosen’t work.
Is there anything that i can do to rescue my past work, or do i have to reinstall and start all over again?

Do you see anything in the logs?

nothing unusual. is there any other log files than /var/log/openhab/ ?

and the basic ui still works.

When editing a Thing I was throwing back one menu on Google Chrome.
The same action on Microsoft Edge working with no problem

Maybe try another browser or clean the browser history
Or use other device to test.

yes i tried another computer, but still same problem.

where the configs are stored? can i check or edit files manually?

You can configure openhab via config files or GUI
if you have chosen the GUI route then there is a database file, but as far as I know it is not the intention to edit it manually.

maybe someone else can comment on this?

It is stored in userdata\jsondb\ uicomponents_ui_page.json

There also is a subfolder backup, there you can find a previous version of the file.

How to restore? I don’t know exactly, maybe others know it better!

1 Like

I would not recommend to edit the files.

Better restore the previous version.

I tried out, now.

Stop openHAB service. (In my case this step was not necessary!)

Go to userdata\jsondb\backup\ and search for something like this:
1609664847127–uicomponents_ui_page.json (discover the date and time of your previous running version).

Copy it to userdata\jsondb\ folder.

Rename your corrupt uicomponents_ui_page.json to uicomponents_ui_page.old

Rename the e.g. 1609664847127–uicomponents_ui_page.json to uicomponents_ui_page.json

(Re)start openHAB service.

Thanks a lot!

This solved the problem,
i replaced all files with backup files and then it started working again,
so i’m not sure which file was causing the problem.

1 Like