[OH3]Migrating from OH2 : no more temperature reading from KNX network

Hello,

Still struggling with OH3, I decided to work with the file-based definition of my things/items, etc … I’m still validating the setup of my 80 KNX participants installation.

I imported my .things and my .items files from OH2 and OH3 found everything working, except some temperature data, which I can’t figure out. For example, in my KNX network, I have group addresses for each set temperature of each room, and group addresses for the effective measured temperature.

In my .things file I have :

Thing device TMDSuite [ address="1.0.38",fetch=false,pingInterval=300,readInterval=3600 ] 
     {
Type number : cTempSuite "Temp. suite parentale [%.1f °C]"  [ ga="9.001:3/2/6" ]
     }

and further :

Thing device generic
     {
Type number : cTempConsigneSuite "Température de consigne suite parentale" [ ga="9.001:3/3/6+<3/6/6" ]
     }

In my .items file, I have :
Number TempSuite "Temp. suite parentale [%.1f °C]" <temperature> (gTemperature) { channel="knx:device:ABBIPS2_1:TMDSuite:cTempSuite" }

and

Number TempConsigneSuite "Temp. consigne suite parentale [%.1f °C]" <temperature> (gTemperature) { channel="knx:device:ABBIPS2_1:generic:cTempConsigneSuite" }

When I connect to the administration interface of OH3, I find this for all my temperature data :

Every set temperature is correctly read (my goal is to be able to set it once I will succeed to migrate …). But none of the measured temperature is read.

My items and things definition worked well in OH2. Where is my fault ?

Thanks in advance for your answer.

Hi,

If I’ve read you code correctly. It’s a long shot, but perhaps you should try a “<” to indicate read in your things config. Also, you don’t need the DPT in HO3.

Thing device TMDSuite [ address="1.0.38",fetch=false,pingInterval=300,readInterval=3600 ] 
     {
Type number : cTempSuite "Temp. suite parentale [%.1f °C]"  [ ga="<3/2/6" ]
     }

Hello Martin,

Thank you for your interest in my problem.

I have tested the two advices you gave me :

  • removing the DPT from all my ga’s. It seems to work and simplifies the file. Thanks.
  • trying the “<” in front of my Temperature ga in order to recover the values of my temperature sensors. Unfortunately this did not make a change and the values is still NULL.

Is there a possibility to debug the informations on the KNX network inside OH3 ? I mean, I would like to be sure that OH3 reads thoses values effectively. I know that the information of the sensors is sent on the KNX network because I’ve got a Zennio display that shows thoses values.

I have another question : why should I put a “<” in front of those ga’s where I don’t have to, in front of the set temperature values, associated with the generic knx device ?

Thanks for all.

Eric.

Hi, it was a long shot with the “<“.

The optional < sign tells whether the group address of the datapoint accepts read requests on the KNX bus (it does, if the sign is there). Putting “<“ in front of ga’s for setting values is not correct syntax.

Yes, it is possible to set the log level of the KNX service (and other services). In order to do that you have to use Karaf.

sudo ssh -p 8101 openhab@localhost (where openhab is installed)
Default password is habopen.

Here you can set the log level.

log:set LEVEL package.subpackage

See the link below for more details