OH3 MQTT Bug - Sonoff/Tasmota

Hello All,

I am using openhab for a long time and was always using the old MQTT 1.14
But while testing OH3 I found a possible Bug migrating the mqtt Things / Items.
It sends a wrong mqtt command to the server.

(in OH2 with mqtt 2.55 it is working with the same config files)

First: It works if I configure the thing in UI but it does not work with config files:

Example:

mqtt.things File:

Bridge mqtt:broker:mosquitto “Mosquitto MQTT Broker” [ host=“192.168.250.20”, port=1883, secure=false, username=“test”, password="", clientID=“OpenHAB3” ]
{
Thing topic Buero_Decke “Buero” {
Channels:
Type switch : power “Power” [ stateTopic=“stat/buero/POWER”, commandTopic=“cmnd/DVES_9AEF00/POWER”, on=“ON”,off=“OFF”]
}
Thing topic schuppen “schuppen” @ “Another Room” {
Channels:

    Type number : temperature "Temperature"          [ stateTopic="Schuppen/schuppen/Temperature"]
}

}

it attaches: “:command” to the mqtt send

You can also see the wrong command in the UI:

Interesting. Looks like some configurations syntax from v1 still appear - have you completely removed the V1 configurations?

If you think it’s a bug, please report here: Issues · openhab/openhab-addons · GitHub

And welcome!

It is a complete new VM running OH3, I did not migrate the config. Started with a clean config.
So that can not come from an old v1 config.

Hello All,

I just so created the things again with the same settings and a diffrent name, now it is working.
Have no idea what it was.

But Thanks anyway :wink:

Hello, Openhab 3.0 does not seem very stable. I’m having problems too.