OH3: Pages and HabPanel don't show Item states

  • Platform information:
    • Hardware: Raspi 4B 4GB 120GB SSD
    • OS: OH3 Image
    • Java Runtime Environment: latest
    • openHAB version: 3.1.0
  • Issue of the topic:
    I’m currently deploying a new OH3 instance in parallel to my active OH2.5 instance which is working as expected. The new OH3 setup is UI based only and not file based as the OH2.5 instance is.
    I implement it stepwise and all Things, Items work as expected. The Items show their current values and via Analyze I see the history. All seems to work.

Now I tried to setup a HabPanel as I have it running on the parallel (own Raspi HW instance and IP).
I can define panels, place Widgets and configure them like in OH2.5 but after saving and running them I get nothing but the red warning that the “connection is lost and it’s trying to reconnect”. What is wrong here? I have no clue.

As a next step I tried to setup a first Page via UI. I defined I first cell but I don’t get the value of the Item. I tried several things and googled for similar problems without success.
Bildschirmfoto 2021-07-09 um 10.13.31

What is missing in my OH3 system or what did I wrong.

Thanks for help in advance.


  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Your Item appears to be of Number:Volume type, but is I suspect linked to a KNX channel of number only type (no units)

I changed it to Number - but nothing changed in Pages.

For the HabPanel issue it cannot be the reason.

Isn’t there any idea whats wrong with my installation?

There seem to be a connection problem between the Items and HabPanel / Pages.

Thanks Helmut