OH3 Problem with writing the data, class org.openhab.core.io.rest.sitemap.internal.PageDTO

Yes, I also have exactly the same problem with IOS app and OH 3.3M1

I placed a request to the German OH-Facebook group where another user recommended to start with an OOTB installation and a backup w/o --full. I did so, placed a new image on my SSD with balana etcher, installed Grafana, Deconz, InfluxDB, MQTT Broker… and gave it a try. Unfortunately w/o success. Just today when I wanted to view my logs I realized that ZRAM was still running (using an SSD - so no need). I uninstalled it, restarted and now my OH on the iphone works. Not sure if it also does tomorrow - but it is a first step. And maybe helps you, @Sankisan or other users as well as developers?

EDIT: Two hours later the same error came up again :frowning:

is there a ticket open on GitHub for this?

same issue here (3.3.0 #2690)

I didn’t find any.

I had to edit my answer - it appears again.

can you please open it? just to be sure this issue will be tracked properly.

Here we go: https://github.com/openhab/openhab-addons/issues/12387

The ticket has been marked as closed. Solution: Update to recent milestone 3.3, I did it, result: OH still throws “Interceptor” warnings when using the IOS app - but the system does not crash completely anymore.

I am on 3.3.0 (# 2766) and the issue is still there

Hello,
since yesterday I have the same problem with iOS openhab app. My sitemap on windows desktop is working fine. Same sitemap on iOS is empty and shows not a single item.

Hope this issue is fixed soon!

Hi, I think this is a different issue @Mario084 . In the app of @ariela and me, the whole OH crashed once we start(ed) the ios app. Did you select the correct sitemap in ios?

Hi Christoph,

thanks for your reply! Alright…
Yes I defined the correct sitemap in the iOS app…

As I already mentioned the sitemap is still working fine on any browser…
Need to check some more logs to identify the issue if it´s not an general issue with the app.

On my Android tab the openhab app with the sitemap is working correctly. So I guess it is an iOS app issue…

I’d like to add myself to those experiencing the same problem.

So, just to be clear, we cannot resolve this issue without upgrading to an unstable version?

Hardly seems like a solution to me.

@psych You don’t even resolve the bug if you switch to the latest Milestone. The system does not crash anymore when you open the iphone app - but the “Interceptor” still throws errors…

Without the switch to the latest milestone I am not aware of any potential solution. I also don’t understand the bug…

Issue 12387 is closed code is merged but on 3.3.0.M5 - Milestone Build this issue is still present (at least for me). How it looks for others?

1 Like

Still the same - was just checking for updates - but maybe it might be solved with 3.4? Anybody any news?

Since the latest update to M7 yesterday this bug disapeared for me :smiley:

Maybe others will try as well?

Ofcourse it will not show up anymore :slight_smile:
See this

I have opened the issue and J-N-K applied the patch to hide it.