OH3 problems with USB boot


I have a pi 4 and want to boot from USB. I have done it from the openhabian-config.
It will not boot from USB when th SD card is removed. With the SD card installed it boots from USB.

Have anybody any solution here?


I did nothing in openhab-config.
Burned the SD on a SSD, removed SD and connected SSD by USB.
That’s all :slightly_smiling_face:

1 Like

Thank you Christian.

I shall try it.

This is not supported in openHABian (for a number of good reasons).

Hi Markus.

I have had problems with SD cards and this is because when the power have been away for some reason, the data on the SD card is were often corrupted and you have to install the image again.An SSD drive have more resistance for this.
If you use Z-ram everthing is still on the SD card when you shall boot.

I have OH1 running now on a pidrive and it have worked without problems, it have been so many years ago since I started it, so I had forgotten all about it when I should start to go over to OH3 :slight_smile:

I thought, I did it the same way a long time ago.
But when I tried it this time it did not work:

  1. Save SD-card image with Win32Diskimager
  2. Write SD-card Image to USB SSD
  3. Connect SSD to RPi4 USB (no SD-card)
  4. Does not boot up (still investigating what might be wrong).

So you did not change something manually on the USB SSD (like fstab / cmdline.txt), right?

No, I did not change any file
I copied SD image and wrote image on SSD, same as you mentioned above.
Have you checked bootloader version?

vcgencmd bootloader_version

As far as I remember it must be from about Aug. 20, mine is from Sept.

1 Like

Sept 3rd.
It used to work with another SSD on USB already.

I found out that the other USB SSD obviously does not work on the RPi4.
Maybe the controller in the external housing is the problem!?

Anyway, thanks for your confirmation!

1 Like

Try the 64 bit beta version of openhabian, for me that’s works with my pi4. There was no other way to get it to boot with the 32bit versions and I really didn’t want to use sd cards as I’m very dedicated to openhab.

Have to admit my openhab is far from stable at the moment and have no clue if it is the 64bit version.

[edit] - looks like openhab is pretty stable, the issues I had where due to own f*ckups :slight_smile:

1 Like

I can boot my Pi4 with 32 bit and USB SSD.
And because the 64-bit is not yet recommended, I will wait a little longer.
But it’s good to know, that it’s working well.
Thanks again!

how did you manage to get the 32bit version to boot? copy the .elf and .dat files from the 64bit version to the boot partition, that didn’t work for me though…

I do not know from where you are starting.
I have a Pi4 with 4GB so I am on openhabian 32bit.

There is nothing to copy or change, just burn SD image on SSD and it will boot.
But as NCO mentioned above there are some SATA/USB controllers which do not work, google is your friend here.

1 Like

Yeah I know that some don’t work. This one does work obviously :smiley: (Google was my friend haha).

But strange, I’m pretty sure the 32bit version didn’t work… maybe I will give it another try sometime.

Thnx for your reply!

1 Like