OH3 - still openhab2 logfile folder

Hi all,

I am already running oh 3.0.0 (openhabian).
I installed frontail and able to access the webgui, BUT frontail is linked to

/var/log/openhab/openhab.log /var/log/openhab/events.log

I checked the dir and i have only an openhab2 folder under /var/log.

Any hints?

Thank you

/var/log/openhab will be created if openhab is running. You must convert all samba folders if you use samba also set to openhab without 2.
Everything will be as before.

my openhab is running :smile:
This is actually my problem. I am running OH3 but still only see openhab2 logfile folder

If there is no folder maybe you have some rights issue. Via openhabian-config you can fix all right issues. Please try it.

Received - There was an error or interruption during the execution of “10 Apply Improvements”

2020-12-22_14:05:24_CET [openHABian] Applying file permissions recommendations… FAILED (openhab folders)

Should i try to reinstall frontail via openhabian-config?

Thank you

Did you execute with sudo then i have no idea whats the issue is at this point. Maybe a search via forum can help.

I have manually created the openhab folder under /var/log now.
When i check the service status i see the permission error:
Dec 22 14:28:25 openhab3 karaf[8246]: Caused by: java.io.FileNotFoundException: /var/log/openhab/openhab.log (Permission denied)

I have now modified the permission and openhab was able to create the logfile.
Anyway after a reboot the folder /var/log/openhab was removed automatically. (/var/log/openhab2) still exists.

I’m having exactly the same issue.
Did the same steps, and /var/log/openhab disappeared.

Hi Jag,

afters hours of troubleshooting i decided to start from scratch with the new openhabian image to avoid issues in the future.

So… I had the same issue… I installed openHABian Configuration Tool from instructions found here : openHABian | openHAB
I tried the “Fix permissions” but got “There was an error or interruption during the execution of “10 Apply Improvements”” as others before me.
Then I tried a few other improvements from the configuration tool that seemed safe and after a while the “fix permissions” went through and Openhab 3 eventually started. But also it took a loooooooooong time the first time.

I’m also getting the same error using the OH3 openhabian-config tool.
Applying file permissions recommendations… FAILED (openhab folders)

How did you make it working?
At the moment I’m unable to copy a backup to \openhabiandevice\openHAB-userdata.
Also using WinSCP give me an permission error to /var/lib/openhab/backups

Can I give the permissions manually?

I don’t remember exactly what I’ve done. I know fix permissions did not work when I first tried, then I’ve tried other options of the openhabian-config tool then when I tried fix permissions again it worked.
So it was maybe just luck. I’ll have to try again soon because I had another issue (nothing to do with OH3) and had to use a backup… but I did not have an OH3 backup yet :stuck_out_tongue: