OH3 UI on tablet

I am testing out the new UI on a wall mounted Windows tablet pc (Lenovo)

For some reason standard pop-up windows automatically open full width.

I’ve tested edge and chrome and I get the same. As you can see it is not very practical, the icons and labels are too far away from the buttons.

Is anyone else getting this and is there a workaround?


r.

According to framework7 documentation it should be windowed on tablets:

However I do not know how it is determined which kind of device you are using. Maybe you can try to open the desktop website in case that your browser claims to be a phone!?

thanks…the chrome and edge browser do not have any settings AFAIK. To me they are the same as the standard windows 10. But obviously Openhab is picking up something that causes it to open the popup in a window. I imagine it will be the same on any large touchscreen which is not ideal.

By default Popup has a bit different size on phones and tablets (iPad). On phones it is fullscreen while on tablets it is 630px width and height.

I asume that in your case, it’s the limited height (< 630px), which makes the popup to go fullscreen. There is a popup setting which should?! disable the fullscreen-functionality on tablets:

tabletFullscreen: false

But as you call the popup from a build-in action this might be impossible to set in that case. But not 100% sure and didn’t tested that config prop.

1 Like

yes I’ve just tried zooming out to 90% and that forces it to open as a popup. perhaps in the future that can be added as a flag to the built in widgets. for now this is better thanis for the help…